summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2024-10-02 20:52:34 +0200
committerSven Wegener <swegener@gentoo.org>2024-10-02 22:37:06 +0200
commit00a6497749be7026c6bccbdf582913dc0915ceb5 (patch)
tree503115bfcc7fe91e36918621e10cc4daf5ebcda1 /net-dns
parentx11-misc/spacefm: drop 1.0.6-r3 (diff)
downloadgentoo-00a6497749be7026c6bccbdf582913dc0915ceb5.tar.gz
gentoo-00a6497749be7026c6bccbdf582913dc0915ceb5.tar.bz2
gentoo-00a6497749be7026c6bccbdf582913dc0915ceb5.zip
net-dns/pdns: add 4.9.2
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/Manifest1
-rw-r--r--net-dns/pdns/pdns-4.9.2.ebuild165
2 files changed, 166 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 61c7b1ee2912..e3508864fbe7 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1 +1,2 @@
DIST pdns-4.9.1.tar.bz2 1396230 BLAKE2B 810f655823dc612026ac3548cd432ea6a044ac26018ce0a1b5c29743c5e9b1df775b172dba741a79c1a0537d0d17ed4c5d9f748ac1385803ec83438f250d3cd6 SHA512 8be784615a4b35dd04af7584d1faf3e2b25665b31f83d8f64057ca164a2c4f0604c92c768b88a7b778aa13148fb2d0cedc328551b8c467b7b21011cfc3b33b1a
+DIST pdns-4.9.2.tar.bz2 1378434 BLAKE2B 96a5ae874b3df27f00891d8e6e399fb529371bb70dffa4cb7167887da5ef231809faac1cddfc3ec84a0ccb286487d8c5c9ba5f5b8ed12398260cc5c4f369407f SHA512 42292d5dadadf39077a5be2bb0f973292375e2d0695738bfee73d91681f9e7b0e313343dafa042ce3c7141e3132ee5756cb42eabab2188c02adb44fa07866235
diff --git a/net-dns/pdns/pdns-4.9.2.ebuild b/net-dns/pdns/pdns-4.9.2.ebuild
new file mode 100644
index 000000000000..278cba886e04
--- /dev/null
+++ b/net-dns/pdns/pdns-4.9.2.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic lua-single python-any-r1
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc geoip ldap lmdb lua-records mysql odbc postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ dev-libs/boost:=
+ lmdb? ( >=dev-db/lmdb-0.9.29 )
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4:= app-crypt/mit-krb5 )
+ odbc? ( dev-db/unixODBC )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ elibc_glibc? ( x86? ( >=sys-libs/glibc-2.34 ) )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ python-any-r1_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local cnf_dynmodules="bind lua2 pipe" # the default backends, always enabled
+
+ use geoip && cnf_dynmodules+=" geoip"
+ use ldap && cnf_dynmodules+=" ldap"
+ use lmdb && cnf_dynmodules+=" lmdb"
+ use mysql && cnf_dynmodules+=" gmysql"
+ use odbc && cnf_dynmodules+=" godbc"
+ use postgres && cnf_dynmodules+=" gpgsql"
+ use remote && cnf_dynmodules+=" remote"
+ use sqlite && cnf_dynmodules+=" gsqlite3"
+ use tinydns && cnf_dynmodules+=" tinydns"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${cnf_dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}