summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-30 02:51:11 +0100
committerSam James <sam@gentoo.org>2023-09-30 02:51:11 +0100
commitb63eb1d88fe2e39d50ed26013185067da2d4827c (patch)
treeec1d613e23e33fb3d9b4b3392ad2c9dfaee31dfc /net-dns/c-ares/c-ares-1.19.0.ebuild
parentdev-util/cargo-nextest: add 0.9.59 (diff)
downloadgentoo-b63eb1d88fe2e39d50ed26013185067da2d4827c.tar.gz
gentoo-b63eb1d88fe2e39d50ed26013185067da2d4827c.tar.bz2
gentoo-b63eb1d88fe2e39d50ed26013185067da2d4827c.zip
net-dns/c-ares: drop 1.19.0
Bug: https://bugs.gentoo.org/906964 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/c-ares/c-ares-1.19.0.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.19.0.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-dns/c-ares/c-ares-1.19.0.ebuild b/net-dns/c-ares/c-ares-1.19.0.ebuild
deleted file mode 100644
index 760debb0dc93..000000000000
--- a/net-dns/c-ares/c-ares-1.19.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
-inherit edo multilib-minimal verify-sig
-
-DESCRIPTION="C library that resolves names asynchronously"
-HOMEPAGE="https://c-ares.org/"
-SRC_URI="
- https://c-ares.org/download/${P}.tar.gz
- verify-sig? ( https://c-ares.org/download/${P}.tar.gz.asc )
-"
-
-LICENSE="MIT"
-# Subslot = SONAME of libcares.so.2
-SLOT="0/2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="verify-sig? ( sec-keys/openpgp-keys-danielstenberg )"
-
-DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/ares_build.h
-)
-
-multilib_src_configure() {
- local myeconfargs=(
- --enable-nonblocking
- --enable-symbol-hiding
- $(use_enable static-libs static)
- $(use_enable test tests)
- )
-
- # Needed for running unit tests only
- # Violates sandbox and tests pass fine without
- export ax_cv_uts_namespace=no
- export ax_cv_user_namespace=no
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- cd "${BUILD_DIR}"/test || die
-
- # We're skipping the "real" network tests with the filter
- # see https://github.com/c-ares/c-ares/tree/main/test
- local network_tests=(
- # Most live tests have Live in the name
- *Live*
- # These don't but are still in ares-test-live.cc => live
- *GetTCPSock*
- *TimeoutValue*
- *GetSock*
- *GetSock_virtualized*
- )
-
- # The format for disabling test1, test2, and test3 looks like:
- # -test1:test2:test3
- edo ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}"))
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -name "*.la" -delete || die
-}