summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-15 11:09:21 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-15 11:09:21 -0800
commitd9c877258c6b7321f4305396b19d5bf2441efd8d (patch)
tree781f835adc039c1445d9bb6b92691568ab087418 /net-dns/avahi
parentprofiles: package.mask net-im/zoom-5.17.5.2543, problems at runtime (diff)
downloadgentoo-d9c877258c6b7321f4305396b19d5bf2441efd8d.tar.gz
gentoo-d9c877258c6b7321f4305396b19d5bf2441efd8d.tar.bz2
gentoo-d9c877258c6b7321f4305396b19d5bf2441efd8d.zip
net-dns/avahi: add 0.9_rc1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/Manifest1
-rw-r--r--net-dns/avahi/avahi-0.9_rc1.ebuild203
-rw-r--r--net-dns/avahi/files/avahi-0.9_rc1-disable-avahi-ui-sharp.patch43
3 files changed, 247 insertions, 0 deletions
diff --git a/net-dns/avahi/Manifest b/net-dns/avahi/Manifest
index 8827967c8d22..ac584b7aa178 100644
--- a/net-dns/avahi/Manifest
+++ b/net-dns/avahi/Manifest
@@ -1 +1,2 @@
DIST avahi-0.8.tar.gz 953319 BLAKE2B ddede1b8790ff3057ea5f4bb710e95578229e078a7abac83121e043017dda1ab3d971c723f920fdd4f3d98b88bd2cf21f9645bec1b7bbd2ea194cb399a5f5b46 SHA512 27bba9a551152dfc7e721f326042e7bfce55d227044a6cbaee04d6fb0e3f59c36e159c2b7a4dd42d1c955cdf37cc1c303e91991c08928bbded91d796e9a22abe
+DIST avahi-0.9_rc1.tar.gz 1057252 BLAKE2B f38c35d25c439d0d4dce00131d61d4be816fdcf14ddbe4f91fed95990ac6313b8ed905bca84f693feeccf92b891c849a994cbee80b02732108a18378b044d4b4 SHA512 c46ef2c646ae7a7be8e61ef18924a5c1349e19293ecd2e95f51dd6cd41967ea2f118ca2af48671c68a5b33687cdd6cbadb8745d95e8b69963d0b73f2d447db8d
diff --git a/net-dns/avahi/avahi-0.9_rc1.ebuild b/net-dns/avahi/avahi-0.9_rc1.ebuild
new file mode 100644
index 000000000000..e4f7cb84a6ab
--- /dev/null
+++ b/net-dns/avahi/avahi-0.9_rc1.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="gdbm"
+inherit autotools multilib-minimal python-single-r1 systemd
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="https://avahi.org/"
+SRC_URI="https://github.com/lathiat/avahi/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="autoipd bookmarks +dbus doc gdbm gtk howl-compat +introspection ipv6 mdnsresponder-compat nls python qt5 selinux systemd test"
+
+REQUIRED_USE="
+ python? ( dbus gdbm ${PYTHON_REQUIRED_USE} )
+ bookmarks? ( python )
+ howl-compat? ( dbus )
+ mdnsresponder-compat? ( dbus )
+ systemd? ( dbus )
+"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libdaemon
+ dev-libs/libevent:=[${MULTILIB_USEDEP}]
+ dev-libs/expat
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ gdbm? ( sys-libs/gdbm:=[${MULTILIB_USEDEP}] )
+ qt5? ( dev-qt/qtcore:5 )
+ gtk? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ kernel_linux? ( sys-libs/libcap )
+ introspection? ( dev-libs/gobject-introspection:= )
+ systemd? ( sys-apps/systemd:=[${MULTILIB_USEDEP}] )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ bookmarks? ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}] )
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )
+ ')
+ )
+"
+RDEPEND="
+ acct-user/avahi
+ acct-group/avahi
+ acct-group/netdev
+ autoipd? (
+ acct-user/avahi-autoipd
+ acct-group/avahi-autoipd
+ )
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-avahi )
+"
+BDEPEND="
+ dev-util/glib-utils
+ doc? ( app-text/doxygen )
+ app-text/xmltoman
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/avahi-qt5/qt-watch.h )
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-avahi-ui-sharp.patch" # bug 769062
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use ipv6; then
+ sed -i \
+ -e "s/use-ipv6=yes/use-ipv6=no/" \
+ avahi-daemon/avahi-daemon.conf || die
+ fi
+
+ sed -i \
+ -e "s:\\.\\./\\.\\./\\.\\./doc/avahi-docs/html/:../../../doc/${PF}/html/:" \
+ doxygen_to_devhelp.xsl || die
+
+ eautoreconf
+
+ # bundled manpages
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-gtk
+ --disable-mono
+ --disable-monodoc
+ --disable-python-dbus
+ --disable-qt3
+ --disable-qt4
+ --disable-static
+ --enable-manpages
+ --enable-glib
+ --enable-gobject
+ --enable-xmltoman
+ --localstatedir="${EPREFIX}/var"
+ --runstatedir="${EPREFIX}/run"
+ --with-distro=gentoo
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable dbus)
+ $(use_enable gdbm)
+ $(use_enable gtk gtk3)
+ $(use_enable howl-compat compat-howl)
+ $(use_enable mdnsresponder-compat compat-libdns_sd)
+ $(use_enable nls)
+ $(use_enable systemd libsystemd)
+ $(multilib_native_use_enable autoipd)
+ $(multilib_native_use_enable doc doxygen-doc)
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable python)
+ $(multilib_native_use_enable test tests)
+ )
+
+ if use python; then
+ myconf+=(
+ $(multilib_native_use_enable dbus python-dbus)
+ $(multilib_native_use_enable introspection pygobject)
+ )
+ fi
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # used by daemons only
+ --disable-libdaemon
+ --with-xml=none
+ )
+ fi
+
+ myconf+=( $(multilib_native_use_enable qt5) )
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ multilib_is_native_abi && use doc && emake avahi.devhelp
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+
+ if ! use bookmarks || ! use python || ! use dbus; then
+ rm -f "${ED}"/usr/bin/avahi-bookmarks || die
+ fi
+
+ # https://github.com/lathiat/avahi/issues/28
+ use howl-compat && dosym avahi-compat-howl.pc /usr/$(get_libdir)/pkgconfig/howl.pc
+ use mdnsresponder-compat && dosym avahi-compat-libdns_sd/dns_sd.h /usr/include/dns_sd.h
+
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doxygen/html/.
+ insinto /usr/share/devhelp/books/avahi
+ doins avahi.devhelp
+ fi
+
+ # The build system creates an empty "/run" directory, so we clean it up here
+ rmdir "${ED}"/run || die
+}
+
+multilib_src_install_all() {
+ use python && python_optimize
+
+ if use autoipd; then
+ insinto /lib/rcscripts/net
+ doins "${FILESDIR}"/autoipd.sh
+
+ insinto /lib/netifrc/net
+ newins "${FILESDIR}"/autoipd-openrc.sh autoipd.sh
+ fi
+
+ dodoc docs/{AUTHORS,NEWS,README,TODO}
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ if use autoipd; then
+ elog
+ elog "To use avahi-autoipd to configure your interfaces with IPv4LL (RFC3927)"
+ elog "addresses, just set config_<interface>=( autoipd ) in /etc/conf.d/net!"
+ elog
+ fi
+
+ systemd_reenable avahi-daemon.service
+}
diff --git a/net-dns/avahi/files/avahi-0.9_rc1-disable-avahi-ui-sharp.patch b/net-dns/avahi/files/avahi-0.9_rc1-disable-avahi-ui-sharp.patch
new file mode 100644
index 000000000000..587bd315856e
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.9_rc1-disable-avahi-ui-sharp.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile.am b/Makefile.am
+index 33c51f5..0e12120 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -46,7 +46,6 @@ EXTRA_DIST = \
+ avahi-qt4.pc.in \
+ avahi-qt5.pc.in \
+ avahi-sharp.pc.in \
+- avahi-ui-sharp.pc.in \
+ avahi-compat-libdns_sd.pc.in \
+ avahi-compat-howl.pc.in \
+ avahi-ui.pc.in \
+@@ -77,7 +76,6 @@ SUBDIRS = \
+ avahi-compat-howl \
+ avahi-autoipd \
+ avahi-ui \
+- avahi-ui-sharp \
+ avahi-libevent \
+ po
+
+@@ -188,8 +186,8 @@ CLEANFILES += avahi-compat-libdns_sd.pc
+ endif
+
+ if HAVE_MONO
+-pkgconfig_DATA += avahi-sharp.pc avahi-ui-sharp.pc
+-CLEANFILES += avahi-sharp.pc avahi-ui-sharp.pc
++pkgconfig_DATA += avahi-sharp.pc
++CLEANFILES += avahi-sharp.pc
+ endif
+
+ endif
+diff --git a/configure.ac b/configure.ac
+index 2f63730..fed400d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1183,7 +1183,6 @@ man/Makefile
+ tests/Makefile
+ service-type-database/Makefile
+ avahi-sharp/Makefile
+-avahi-ui-sharp/Makefile
+ avahi-compat-libdns_sd/Makefile
+ avahi-compat-howl/Makefile
+ avahi-compat-howl/samples/Makefile