summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-14 15:14:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-14 15:15:06 +0300
commitccd1860647f01c037c1e6d26c3a2d01c87f3196d (patch)
tree0124faa85c97228c94cd9458ffbcb987d4556c0e /net-dialup
parentdev-python/fuzzywuzzy: fix variable order (diff)
downloadgentoo-ccd1860647f01c037c1e6d26c3a2d01c87f3196d.tar.gz
gentoo-ccd1860647f01c037c1e6d26c3a2d01c87f3196d.tar.bz2
gentoo-ccd1860647f01c037c1e6d26c3a2d01c87f3196d.zip
net-dialup/speedtouch-usb: EAPI=8, refactor, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r3.ebuild92
-rw-r--r--net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r4.ebuild75
2 files changed, 75 insertions, 92 deletions
diff --git a/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r3.ebuild b/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r3.ebuild
deleted file mode 100644
index c8dc23c17618..000000000000
--- a/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info
-
-DESCRIPTION="Firmware and configuration instructions for Alcatel SpeedTouch USB modems"
-HOMEPAGE="http://www.speedtouch.com/"
-SRC_URI="http://www.speedtouch.com/download/drivers/USB/SpeedTouch330_firmware_${PV//./}.zip"
-
-# Taken from http://www.speedtouch.com/driver_upgrade_lx_3.0.1.2.htm
-LICENSE="SpeedTouch-USB-Firmware"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-
-RDEPEND="net-dialup/ppp"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-src_install() {
- local FILE_VER="${PV#*.}"
- FILE_VER="${PV%%.*}.${FILE_VER//./}" # {major_ver}.{minor_digits}
-
- # Extract the "stage 1" portion of the firmware
- dd if=KQD6_${FILE_VER} of=speedtch-1.bin.2 \
- ibs=1 obs=991 count=991 skip=36 &> /dev/null \
- || die "Extraction of stage 1 firmware (step 1) failed"
-
- dd if=ZZZL_${FILE_VER} of=speedtch-1.bin.4 \
- ibs=1 obs=935 count=935 skip=32 &> /dev/null \
- || die "Extraction of stage 1 firmware (step 2) failed"
-
- # Extract the "stage 2" portion of the firmware
- dd if=KQD6_${FILE_VER} of=speedtch-2.bin.2 \
- ibs=1 obs=762650 count=762650 skip=1027 &> /dev/null \
- || die "Extraction of stage 2 firmware (step 1) failed"
-
- dd if=ZZZL_${FILE_VER} of=speedtch-2.bin.4 \
- ibs=1 obs=775545 count=775545 skip=967 &> /dev/null \
- || die "Extraction of stage 2 firmware (step 2) failed"
-
- # Copy to the firmware directory
- insinto /lib/firmware
- insopts -m 600
- doins speedtch-{1,2}.bin.{2,4}
-
- # Symlinks for other revisions of the modem
- pushd "${D}/lib/firmware" >/dev/null || die
- for n in 1 2 ; do
- for rev in 0 1 ; do
- ln -sfn speedtch-${n}.bin.2 speedtch-${n}.bin.${rev}
- done
- # Seems like a reasonable guess, for revision 3
- ln -sfn speedtch-${stub}${n}.bin.4 speedtch-${n}.bin.3
- done
- popd >/dev/null || die
-
- # Documentation necessary to complete the setup
- dodoc "${FILESDIR}/README"
-}
-
-pkg_postinst() {
- [[ -e /etc/hotplug/usb.usermap ]] && grep -E -q " 0x06[bB]9 +0x4061 " /etc/hotplug/usb.usermap && \
- ewarn "Please remove the SpeedTouch line from /etc/hotplug/usb.usermap"
-
- # Check kernel configuration
- local CONFIG_CHECK="~FW_LOADER ~NET ~PACKET ~ATM ~NETDEVICES ~USB_DEVICEFS ~USB_ATM ~USB_SPEEDTOUCH \
- ~PPP ~PPPOATM ~PPPOE ~ATM_BR2684"
- local WARNING_PPPOATM="CONFIG_PPPOATM:\t is not set (required for PPPoA links)"
- local WARNING_PPPOE="CONFIG_PPPOE:\t is not set (required for PPPoE links)"
- local WARNING_ATM_BR2684="CONFIG_ATM_BR2684:\t is not set (required for PPPoE links)"
- check_extra_config
- echo
-
- # Check user-space for PPPoA support
- if ! has_version net-dialup/ppp[atm] ; then
- ewarn "Run the following command if connecting via PPPoA protocol:"
- ewarn " euse -E atm && emerge net-dialup/ppp"
- echo
- fi
- # Check user-space for PPPoE support
- if ! has_version net-dialup/linux-atm ; then
- ewarn "Run the following command if connecting via PPPoE protocol:"
- ewarn " emerge net-dialup/linux-atm"
- echo
- fi
-
- ewarn "To complete the installation, you must read the documentation in"
- ewarn " ${ROOT}usr/share/doc/${PF}"
-}
diff --git a/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r4.ebuild b/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r4.ebuild
new file mode 100644
index 000000000000..1431187f2355
--- /dev/null
+++ b/net-dialup/speedtouch-usb/speedtouch-usb-3.0.1.2-r4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo linux-info optfeature
+
+DESCRIPTION="Firmware and configuration instructions for Alcatel SpeedTouch USB modems"
+HOMEPAGE="http://www.speedtouch.com/"
+SRC_URI="http://www.speedtouch.com/download/drivers/USB/SpeedTouch330_firmware_${PV//./}.zip"
+S=${WORKDIR}
+
+# Taken from http://www.speedtouch.com/driver_upgrade_lx_3.0.1.2.htm
+LICENSE="SpeedTouch-USB-Firmware"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="net-dialup/ppp"
+BDEPEND="app-arch/unzip"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ local CONFIG_CHECK="~FW_LOADER ~NET ~PACKET ~ATM ~NETDEVICES ~USB_DEVICEFS ~USB_ATM ~USB_SPEEDTOUCH \
+ ~PPP ~PPPOATM ~PPPOE ~ATM_BR2684"
+ local WARNING_PPPOATM="CONFIG_PPPOATM:\t is not set (required for PPPoA links)"
+ local WARNING_PPPOE="CONFIG_PPPOE:\t is not set (required for PPPoE links)"
+ local WARNING_ATM_BR2684="CONFIG_ATM_BR2684:\t is not set (required for PPPoE links)"
+ check_extra_config
+ fi
+}
+
+src_compile() {
+ local VER=$(ver_rs 2-4 '') # {major_ver}.{minor_digits}
+
+ # Extract the "stage 1" portion of the firmware
+ edob -m "Extraction of stage 1 firmware (step 1)" \
+ dd if=KQD6_${VER} of="${T}/speedtch-1.bin.2" ibs=1 obs=991 count=991 skip=36
+ edob -m "Extraction of stage 1 firmware (step 2)" \
+ dd if=ZZZL_${VER} of="${T}/speedtch-1.bin.4" ibs=1 obs=935 count=935 skip=32
+
+ # Extract the "stage 2" portion of the firmware
+ edob -m "Extraction of stage 2 firmware (step 1)" \
+ dd if=KQD6_${VER} of="${T}/speedtch-2.bin.2" ibs=1 obs=762650 count=762650 skip=1027
+ edob -m "Extraction of stage 2 firmware (step 2)" \
+ dd if=ZZZL_${VER} of="${T}/speedtch-2.bin.4" ibs=1 obs=775545 count=775545 skip=967
+}
+
+src_install() {
+ # Copy to the firmware directory
+ insinto /lib/firmware
+ insopts -m 600
+ doins "${T}"/speedtch-{1,2}.bin.{2,4}
+
+ # Symlinks for other revisions of the modem
+ for n in 1 2 ; do
+ dosym speedtch-${n}.bin.2 /lib/firmware/speedtch-${n}.bin.0
+ dosym speedtch-${n}.bin.2 /lib/firmware/speedtch-${n}.bin.1
+ # Seems like a reasonable guess, for revision 3
+ dosym speedtch-${n}.bin.4 /lib/firmware/speedtch-${n}.bin.3
+ done
+
+ # Documentation necessary to complete the setup
+ dodoc "${FILESDIR}/README"
+}
+
+pkg_postinst() {
+ [[ -e /etc/hotplug/usb.usermap ]] && grep -E -q " 0x06[bB]9 +0x4061 " /etc/hotplug/usb.usermap && \
+ ewarn "Please remove the SpeedTouch line from /etc/hotplug/usb.usermap"
+
+ optfeature "connecting via PPPoA protocol" "net-dialup/ppp[atm]"
+ optfeature "connecting via PPPoE protocol" "net-dialup/linux-atm"
+
+ ewarn "To complete the installation, you must read the documentation in"
+ ewarn " ${ROOT}/usr/share/doc/${PF}"
+}