summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/dtrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/dtrace')
-rw-r--r--net-dialup/dtrace/Manifest2
-rw-r--r--net-dialup/dtrace/dtrace-2.01-r2.ebuild35
-rw-r--r--net-dialup/dtrace/metadata.xml14
3 files changed, 51 insertions, 0 deletions
diff --git a/net-dialup/dtrace/Manifest b/net-dialup/dtrace/Manifest
new file mode 100644
index 000000000000..df218bc0302d
--- /dev/null
+++ b/net-dialup/dtrace/Manifest
@@ -0,0 +1,2 @@
+DIST dtrace-2.01-readme.txt 2720 SHA256 6f199e32d3d5ffedb2a15d893afbc4fe8c6675145d4ffe470524768cea709334 SHA512 1c8129ce59e7a997789873cb0d97b72938695ab56034878bb785c1227869e40b5dfb94448791fb5b95105d28b376c6b2e6bb4662a99eaecf72e6438611bb82a8 WHIRLPOOL 5cfa2ae1c3c531fb40599b9c39b2c83600ddd7a4f97b69860338900bb7983341ac112f34898a940d61d354439c99c5a59198b697a3d48090e71580201e696cb0
+DIST dtrace-2.01.static 596114 SHA256 3718b3ad6de37c089a698abc771431a4916c58c67f1e9eefd016b128897b5a78 SHA512 d711ca6fa0870fabd22424d2480642e3e4b966eae6f3ab6d1f835e348d282c369c436a742db7e9a9d6c3cfdaeb07a5fe97bebdb76baec4aa1c83ba710c2e32e9 WHIRLPOOL 14eda2bb4e60a80b61adc06b39b58155759a5f4cd4c1acab367a00d92dae48eb706f673b7585e7b1c506b1e0149155ce6d6ce5d3caad47b1b4d038dc2b100903
diff --git a/net-dialup/dtrace/dtrace-2.01-r2.ebuild b/net-dialup/dtrace/dtrace-2.01-r2.ebuild
new file mode 100644
index 000000000000..8c32f3b4704b
--- /dev/null
+++ b/net-dialup/dtrace/dtrace-2.01-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="DTRACE traces ISDN messages with AVM ISDN-controllers"
+HOMEPAGE="ftp://ftp.avm.de/develper/d3trace/"
+SRC_URI="ftp://ftp.avm.de/develper/d3trace/linux/dtrace.static -> ${P}.static
+ ftp://ftp.avm.de/develper/d3trace/linux/readme.txt -> ${P}-readme.txt"
+
+LICENSE="AVM-dtrace"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="mirror bindist"
+
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${P}.static "${DISTDIR}"/${P}-readme.txt . || die
+}
+
+src_prepare() {
+ edos2unix ${P}-readme.txt
+}
+
+src_install() {
+ exeinto /opt/bin
+ newexe ${P}.static dtrace-avm
+ newdoc ${P}-readme.txt README
+}
diff --git a/net-dialup/dtrace/metadata.xml b/net-dialup/dtrace/metadata.xml
new file mode 100644
index 000000000000..3017626ca0de
--- /dev/null
+++ b/net-dialup/dtrace/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+ <longdescription lang="en">
+ DTRACE is a console application for Linux and traces ISDN messages with
+ AVM ISDN-controllers. The program uses manufacturer specific functions
+ for tracing and does not work with ISDN cards from other manufacturers.
+ </longdescription>
+</pkgmetadata>