summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-23 18:54:49 +0100
committerSam James <sam@gentoo.org>2023-04-23 18:57:01 +0100
commit7717e889523810d417c96888b4f86febada01ee1 (patch)
tree75f5e498774cde814a3417a0805181626b6b4eed /net-analyzer
parentdev-libs/apache-arrow: rm extra test files (diff)
downloadgentoo-7717e889523810d417c96888b4f86febada01ee1.tar.gz
gentoo-7717e889523810d417c96888b4f86febada01ee1.tar.bz2
gentoo-7717e889523810d417c96888b4f86febada01ee1.zip
net-analyzer/nfdump: add 1.7.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nfdump/Manifest1
-rw-r--r--net-analyzer/nfdump/nfdump-1.7.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index 2e99529dd136..de5b5e823bf0 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1,2 +1,3 @@
DIST nfdump-1.6.24.tar.gz 647945 BLAKE2B 6f054c7ccdbc6c5052d1c4655509414b9acc7de320152e932dd31d6cc9eb915b73efa29e42a212ea206c4619c9e025bfd751762808fd8136c38d4edb72f4fabf SHA512 b1e092663ce245247af721565139eb0a264918747e6c0695c59f0b70a99049e92d79674d75c248f60aa832949d7e13027887cc825e393fce7dc5571771bce1d7
DIST nfdump-1.7.0.1.tar.gz 740435 BLAKE2B dd3d3e63aa076b32e0c9e897b40d3ee8368990792b1a483b69a448dadd7389c23df9800910baad0c5a241a480c5961616c70040fdce992b2a67e3be6680e715b SHA512 5b5da57016dc826650ba80a80a881ab89034778316f47c6797dbc902ed6af6d77cfb722356c3a1d92a4239a934178df56ff4c6cb3bf77e029232e02b905ec1a8
+DIST nfdump-1.7.2.tar.gz 697405 BLAKE2B cf52f2cca5d80070bc00c7a7a87cc4820f04904ddeeebd4fc93cf3a2433bcf5798191daa86f0bfc7ee1f2f92e5d8bb087114d2c17e32b641a224189aeb54f822 SHA512 858d0aaae24f2e38f3708db9fd5cd40e99a6a50d5da5738c8ce4bf898fb153ce439c504d5fe8fb3c296d0069511a6f229ebdfc117f849a482e5ffdf457f06003
diff --git a/net-analyzer/nfdump/nfdump-1.7.2.ebuild b/net-analyzer/nfdump/nfdump-1.7.2.ebuild
new file mode 100644
index 000000000000..8b1c7b15fed6
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.7.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow"
+
+REQUIRED_USE="?? ( jnat nsel )"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )
+ ftconv? ( net-analyzer/flow-tools )
+ nfpcapd? ( net-libs/libpcap )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ app-alternatives/yacc
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use doc; then
+ doxygen -u doc/Doxyfile.in || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ # bug #853763
+ use elibc_musl && append-libs "-lfts"
+
+ # --without-ftconf is not handled well, bug #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfpcapd && echo --enable-nfpcapd) \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable debug devel) \
+ $(use_enable jnat) \
+ $(use_enable nsel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/nfcapd.initd nfcapd
+ newconfd "${FILESDIR}"/nfcapd.confd nfcapd
+
+ if use doc; then
+ dodoc -r doc/html
+ fi
+}