summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-25 15:59:24 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-25 16:01:55 +0100
commit648401f62dac58e4e23aa3d7f7215dfd82129a30 (patch)
treea21bdf74c12b7d1f0c5356214d2f376523a25350 /net-analyzer
parentdev-cpp/antlr-cpp: Fix src_test breakage, closes bug #569230 (diff)
downloadgentoo-648401f62dac58e4e23aa3d7f7215dfd82129a30.tar.gz
gentoo-648401f62dac58e4e23aa3d7f7215dfd82129a30.tar.bz2
gentoo-648401f62dac58e4e23aa3d7f7215dfd82129a30.zip
net-analyzer/nmap: Conditionally make makefile.dep (bug #569678 by iGentoo).
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/nmap-7.01.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-analyzer/nmap/nmap-7.01.ebuild b/net-analyzer/nmap/nmap-7.01.ebuild
index dd19efc9d733..9c90f5af3cc2 100644
--- a/net-analyzer/nmap/nmap-7.01.ebuild
+++ b/net-analyzer/nmap/nmap-7.01.ebuild
@@ -132,7 +132,11 @@ src_configure() {
src_compile() {
local directory
- for directory in . libnetutil ncat nmap-update nping nsock/src; do
+ for directory in . libnetutil nsock/src \
+ $(usex ncat ncat '') \
+ $(usex nmap-update nmap-update '') \
+ $(usex nping nping '')
+ do
emake -C "${directory}" makefile.dep
done