summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-04-20 00:59:34 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-04-20 01:01:17 +0200
commit5c459c83b550984629c1fefc7191a6987e189d83 (patch)
treef4dcd1174b5fd494ecfb93a3a9e81a48dafeae73 /net-analyzer/wapiti/wapiti-3.0.3.ebuild
parentdev-python/requests-ntlm: works with python 3.8 (diff)
downloadgentoo-5c459c83b550984629c1fefc7191a6987e189d83.tar.gz
gentoo-5c459c83b550984629c1fefc7191a6987e189d83.tar.bz2
gentoo-5c459c83b550984629c1fefc7191a6987e189d83.zip
net-analyzer/wapiti: add python 3.8 and fix tests
Releases do not have tests included, dropped them in 3.0.3 and fixed call/dependencies in live ebuild Closes: https://bugs.gentoo.org/714688 Closes: https://bugs.gentoo.org/718428 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.0.3.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.3.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.0.3.ebuild b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
index c9bf7dc9b105..b0eb5e96506a 100644
--- a/net-analyzer/wapiti/wapiti-3.0.3.ebuild
+++ b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE='xml'
inherit distutils-r1
@@ -16,13 +16,8 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="kerberos ntlm test"
+IUSE="kerberos ntlm"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
@@ -35,6 +30,5 @@ RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
S=${WORKDIR}/${MY_P}
python_prepare_all() {
- sed -e 's/"pytest-runner"//' -i setup.py || die
distutils-r1_python_prepare_all
}