summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-09-26 07:50:20 +0200
committerJeroen Roovers <jer@gentoo.org>2015-09-26 07:53:43 +0200
commit0192a00a6f8831cb64e6359045105b6d525fdc36 (patch)
tree445b14c0aaaa200a8d0ef8b3682b747a5d355fe2 /net-analyzer/nodebrain/nodebrain-0.9.04.ebuild
parentnet-analyzer/nb: Version bump. (diff)
downloadgentoo-0192a00a6f8831cb64e6359045105b6d525fdc36.tar.gz
gentoo-0192a00a6f8831cb64e6359045105b6d525fdc36.tar.bz2
gentoo-0192a00a6f8831cb64e6359045105b6d525fdc36.zip
net-analyzer/nodebrain: pkgmove
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-analyzer/nodebrain/nodebrain-0.9.04.ebuild')
-rw-r--r--net-analyzer/nodebrain/nodebrain-0.9.04.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/nodebrain/nodebrain-0.9.04.ebuild b/net-analyzer/nodebrain/nodebrain-0.9.04.ebuild
new file mode 100644
index 000000000000..0afe27b8582e
--- /dev/null
+++ b/net-analyzer/nodebrain/nodebrain-0.9.04.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}