summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-13 14:03:40 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-13 14:03:40 +0300
commitc07b33415ae82c6298a9aab563fd5153f3730025 (patch)
treeed9f05d777bdd4070f3a3136eec04370681eddff /net-analyzer/bing/bing-1.1.3-r2.ebuild
parentapp-emulation/x48: Drop old (diff)
downloadgentoo-c07b33415ae82c6298a9aab563fd5153f3730025.tar.gz
gentoo-c07b33415ae82c6298a9aab563fd5153f3730025.tar.bz2
gentoo-c07b33415ae82c6298a9aab563fd5153f3730025.zip
net-analyzer/bing: revbump (EAPI=7)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'net-analyzer/bing/bing-1.1.3-r2.ebuild')
-rw-r--r--net-analyzer/bing/bing-1.1.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/bing/bing-1.1.3-r2.ebuild b/net-analyzer/bing/bing-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..83f643000e81
--- /dev/null
+++ b/net-analyzer/bing/bing-1.1.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A point-to-point bandwidth measurement tool"
+SRC_URI="mirror://debian/pool/main/b/bing/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://fgouget.free.fr/bing/index-en.shtml"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~arm ia64 ppc sparc x86"
+
+src_prepare() {
+ default
+ sed -i -e "s:#COPTIM = -g: COPTIM = ${CFLAGS}:" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bing
+ doman unix/bing.8
+ dodoc ChangeLog Readme.{1st,txt}
+}