summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHan Gao <rabenda.cn@gmail.com>2022-03-12 21:26:50 +0800
committerYixun Lan <dlan@gentoo.org>2022-03-14 18:43:50 +0800
commitaf8937c981e9c56681a1bb961cdcee20a47866ac (patch)
tree46bf67d4799c66c7e6eed6bd4f0267e07107f244 /media-video/mplayer
parentmedia-libs/libggiwmh: ~riscv keywording (diff)
downloadgentoo-af8937c981e9c56681a1bb961cdcee20a47866ac.tar.gz
gentoo-af8937c981e9c56681a1bb961cdcee20a47866ac.tar.bz2
gentoo-af8937c981e9c56681a1bb961cdcee20a47866ac.zip
media-video/mplayer: add riscv support
Bug: https://bugs.gentoo.org/812855 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Han Gao <rabenda.cn@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/files/mplayer-1.4-riscv-support.patch14
-rw-r--r--media-video/mplayer/mplayer-1.4-r1.ebuild2
2 files changed, 16 insertions, 0 deletions
diff --git a/media-video/mplayer/files/mplayer-1.4-riscv-support.patch b/media-video/mplayer/files/mplayer-1.4-riscv-support.patch
new file mode 100644
index 000000000000..282cdf3cef85
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-1.4-riscv-support.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/812855
+
+diff --git a/configure b/configure
+index d1aa8cd..bdac866 100755
+--- a/configure
++++ b/configure
+@@ -1761,6 +1761,7 @@ if test -z "$_target" ; then
+ nios2) host_arch=nios2 ;;
+ vax) host_arch=vax ;;
+ xtensa*) host_arch=xtensa ;;
++ riscv*) host_arch=generic ;;
+ *) host_arch=UNKNOWN ;;
+ esac
+ }
diff --git a/media-video/mplayer/mplayer-1.4-r1.ebuild b/media-video/mplayer/mplayer-1.4-r1.ebuild
index e9da1de4a0b1..a73a14ac67fb 100644
--- a/media-video/mplayer/mplayer-1.4-r1.ebuild
+++ b/media-video/mplayer/mplayer-1.4-r1.ebuild
@@ -175,6 +175,8 @@ REQUIRED_USE="
xv? ( X )"
RESTRICT="faac? ( bindist )"
+PATCHES=( "${FILESDIR}/${P}-riscv-support.patch" )
+
pkg_setup() {
if [[ ${PV} == *9999* ]]; then
elog