summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-28 02:18:40 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 02:34:32 +0300
commitd4f22fa39b1eb118214466b1a22b007e078c009f (patch)
tree15a8e4b5ad0c1cc66d13a735436b3315345fb989 /media-video/aegisub/files
parentmedia-video/aegisub: adjust LIBS_LUA placement in luajit unbundle patch (diff)
downloadgentoo-d4f22fa39b1eb118214466b1a22b007e078c009f.tar.gz
gentoo-d4f22fa39b1eb118214466b1a22b007e078c009f.tar.bz2
gentoo-d4f22fa39b1eb118214466b1a22b007e078c009f.zip
media-video/aegisub: remove clang-only options to avoid warnings on gcc
These options only suppress compilation warnings and do not alter compilation itself, so it is safe to remove them. Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/aegisub/files')
-rw-r--r--media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch b/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch
index caecf82a7ff6..3cb268615b3b 100644
--- a/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch
+++ b/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch
@@ -28,3 +28,23 @@ index be657b0..fca48e0 100644
])
])
+diff --git a/src/Makefile b/src/Makefile
+index 60d7101..1f7b2bc 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -182,14 +182,13 @@ endif
+ #####################
+ # SOURCE-LEVEL CFLAGS
+ #####################
+-$(d)MatroskaParser.o_FLAGS := -Wno-sometimes-uninitialized
+ $(d)audio_player.o_FLAGS := $(CFLAGS_ALSA) $(CFLAGS_PORTAUDIO) $(CFLAGS_LIBPULSE) $(CFLAGS_OPENAL)
+ $(d)audio_provider_factory.o_FLAGS := $(CFLAGS_FFMS2)
+ $(d)auto4_base.o_FLAGS := $(CFLAGS_FREETYPE)
+ $(d)charset_detect.o_FLAGS := -D_X86_
+ $(d)font_file_lister_fontconfig.o_FLAGS := $(CFLAGS_FONTCONFIG)
+ $(d)subtitles_provider.o_FLAGS := $(CFLAGS_LIBASS)
+-$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS) -Wno-c++11-narrowing
++$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS)
+ $(d)text_file_reader.o_FLAGS := -D_X86_
+ $(d)video_provider_manager.o_FLAGS := $(CFLAGS_FFMS2)
+ $(d)auto4_lua.o_FLAGS := -I$(TOP)vendor/luajit/include