summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2020-03-21 19:51:14 +0100
committerNick Sarnie <sarnex@gentoo.org>2020-03-23 18:23:04 -0400
commitc017bfe2f324f573dd2e604f75bb6899585489fe (patch)
treed0622aceadd595b06f900dec72091554224f03ad /media-video/aegisub/files
parentwww-apps/cgit: Use epatch_user (diff)
downloadgentoo-c017bfe2f324f573dd2e604f75bb6899585489fe.tar.gz
gentoo-c017bfe2f324f573dd2e604f75bb6899585489fe.tar.bz2
gentoo-c017bfe2f324f573dd2e604f75bb6899585489fe.zip
media-video/aegisub: revbump for patching Makefile to work with make-4.3
upstream pull reqeust: https://github.com/Aegisub/Aegisub/pull/174 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Bug: https://bugs.gentoo.org/713120 X-Thanks: Petr Zima <zima@matfyz.cz> Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/15045 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-video/aegisub/files')
-rw-r--r--media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-makefile-for-make4.3.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-makefile-for-make4.3.patch b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-makefile-for-make4.3.patch
new file mode 100644
index 000000000000..8f94c5a10d5b
--- /dev/null
+++ b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-makefile-for-make4.3.patch
@@ -0,0 +1,21 @@
+commit f4cc905c69ca69c68cb95674cefce4abc37ce046
+Author: wangqr <wangqr@wangqr.tk>
+Date: Mon Feb 17 14:42:07 2020 +0800
+
+ Use target name without directory in $*_OBJ macro
+
+ Fix Aegisub/Aegisub#171
+
+diff --git a/Makefile.target b/Makefile.target
+index 516ef3c24..5c4c5d259 100644
+--- a/Makefile.target
++++ b/Makefile.target
+@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
+ # Libraries contain all object files they depend on (but they may depend on other files)
+ # Not using libtool on OS X because it has an unsilenceable warning about a
+ # compatibility issue with BSD 4.3 (wtf)
+-lib%.a: $$($$*_OBJ)
++lib%.a: $$($$(*F)_OBJ)
+ @$(BIN_MKDIR_P) $(dir $@)
+ $(BIN_AR) cru $@ $(filter %.o,$^)
+ $(BIN_RANLIB) $@