summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2024-08-08 17:26:38 -0400
committerNick Sarnie <sarnex@gentoo.org>2024-08-08 17:31:22 -0400
commitaa3ffb8396032ddd22b68304bdc83d117bd94fbd (patch)
tree959ad4dfb0bd53be92fbd0bae91e49ea9548d088 /media-video/aegisub/aegisub-9999.ebuild
parentnet-im/gajim: add 1.9.3 (diff)
downloadgentoo-aa3ffb8396032ddd22b68304bdc83d117bd94fbd.tar.gz
gentoo-aa3ffb8396032ddd22b68304bdc83d117bd94fbd.tar.bz2
gentoo-aa3ffb8396032ddd22b68304bdc83d117bd94fbd.zip
media-video/aegisub: Fix build with icu 75
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-video/aegisub/aegisub-9999.ebuild')
-rw-r--r--media-video/aegisub/aegisub-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-video/aegisub/aegisub-9999.ebuild b/media-video/aegisub/aegisub-9999.ebuild
index 208e6b0e5adb..530606341ba5 100644
--- a/media-video/aegisub/aegisub-9999.ebuild
+++ b/media-video/aegisub/aegisub-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -75,11 +75,12 @@ PATCHES=(
"${FILESDIR}/3.3.3/${PN}-3.3.3-support-system-gtest.patch"
"${FILESDIR}/3.2.2_p20160518/${PN}-3.2.2_p20160518-tests_luarocks_lua_version.patch"
"${FILESDIR}/3.2.2_p20160518/${PN}-3.2.2_p20160518-fix-boost-181-build.patch"
+ "${FILESDIR}/3.3.3/${PN}-3.3.3-support-icu-75.patch"
)
aegisub_check_compiler() {
- if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++14; then
- die "Your compiler lacks C++14 support."
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++17; then
+ die "Your compiler lacks C++17 support."
fi
}