summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-28 11:45:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-28 12:08:02 +0200
commitc402973a75fdd5ff28aa0789aa301b5b45e6b40b (patch)
tree16144713a8d36002d1517e0426d1491616a4b06d /media-sound
parentgames-util/lutris: add some missing (optional) runtime dependencies (diff)
downloadgentoo-c402973a75fdd5ff28aa0789aa301b5b45e6b40b.tar.gz
gentoo-c402973a75fdd5ff28aa0789aa301b5b45e6b40b.tar.bz2
gentoo-c402973a75fdd5ff28aa0789aa301b5b45e6b40b.zip
media-sound/krecorder: new package, add 23.04.1
Imported from kde overlay, originally created in guru overlay. Thanks-to: Anna “CyberTailor” <cyber@sysrq.in> Bug: https://bugs.gentoo.org/907291 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/krecorder/Manifest1
-rw-r--r--media-sound/krecorder/files/krecorder-23.04.1-cmake.patch77
-rw-r--r--media-sound/krecorder/krecorder-23.04.1.ebuild36
-rw-r--r--media-sound/krecorder/metadata.xml20
4 files changed, 134 insertions, 0 deletions
diff --git a/media-sound/krecorder/Manifest b/media-sound/krecorder/Manifest
new file mode 100644
index 000000000000..529272c3e916
--- /dev/null
+++ b/media-sound/krecorder/Manifest
@@ -0,0 +1 @@
+DIST krecorder-23.04.1.tar.xz 159680 BLAKE2B 12f547ec9b415dd2c143649492e916ad00b2436a2b76699d98a49194ad392c8599a38080af2875daa3892fc0e3bc3e305c44e5884b20aa95a2f1c1e2ccfe175b SHA512 179822e14aa34dce6da230298e20411d629a10a3f349b4554b4db42742953f8be9fd7403da4517063179e513c06ea0faecd948a4e830183cb02f2f4ff1ad6558
diff --git a/media-sound/krecorder/files/krecorder-23.04.1-cmake.patch b/media-sound/krecorder/files/krecorder-23.04.1-cmake.patch
new file mode 100644
index 000000000000..adb94f31209a
--- /dev/null
+++ b/media-sound/krecorder/files/krecorder-23.04.1-cmake.patch
@@ -0,0 +1,77 @@
+From cb60c63a1c266729fec678d0b1ad5d49fa71a0fe Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 May 2023 12:17:58 +0200
+Subject: [PATCH 1/2] Drop unused KF5Config
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 -
+ src/CMakeLists.txt | 2 --
+ 2 files changed, 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 43d62ef..ac753ff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -63,7 +63,6 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS
+ find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
+ Kirigami2
+ I18n
+- Config
+ CoreAddons
+ WindowSystem
+ )
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 664865b..f5576f4 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -26,8 +26,6 @@ target_link_libraries(krecorder
+ Qt5::Multimedia
+ Qt5::Svg
+ KF5::I18n
+- KF5::ConfigCore
+- KF5::ConfigGui
+ KF5::CoreAddons
+ KF5::WindowSystem
+ )
+--
+2.40.1
+
+
+From 75f8647733304fa485d18ed007a44644d5e4d906 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 May 2023 12:23:01 +0200
+Subject: [PATCH 2/2] Mark KF5Kirigami2 RUNTIME required only
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ac753ff..a7a6477 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -60,12 +60,16 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS
+ QuickCompiler
+ )
+
+-find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
+- Kirigami2
+- I18n
++find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
++ I18n
+ CoreAddons
+ WindowSystem
+ )
++
++find_package(KF5Kirigami2 ${KF_MIN_VERSION})
++set_package_properties(KF5Kirigami2 PROPERTIES
++ TYPE RUNTIME
++)
+ find_package(KF5KirigamiAddons 0.6 REQUIRED)
+
+ add_subdirectory(src)
+--
+2.40.1
+
diff --git a/media-sound/krecorder/krecorder-23.04.1.ebuild b/media-sound/krecorder/krecorder-23.04.1.ebuild
new file mode 100644
index 000000000000..ac396ac59bb7
--- /dev/null
+++ b/media-sound/krecorder/krecorder-23.04.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="utilities"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Convergent audio recording application for Plasma"
+HOMEPAGE="https://apps.kde.org/krecorder/"
+
+LICENSE="CC0-1.0 CC-BY-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/kirigami-addons-0.6:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[qml]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+"
+BDEPEND=">=kde-frameworks/ki18n-${KFMIN}:5"
+
+# Pending upstream: https://invent.kde.org/utilities/krecorder/-/merge_requests/22
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
diff --git a/media-sound/krecorder/metadata.xml b/media-sound/krecorder/metadata.xml
new file mode 100644
index 000000000000..5144f75a1df9
--- /dev/null
+++ b/media-sound/krecorder/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="kde-invent">utilities/krecorder</remote-id>
+ <bugs-to>https://bugs.kde.org/enter_bug.cgi?product=krecorder</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Krecorder is a convergent audio recording application for Plasma.
+ Features:
+ - Record audio with a visualizer, and pausing functionality
+ - Ability to select audio sources
+ - Ability to select encoding and container formats
+ - Audio playback with a visualizer
+ </longdescription>
+</pkgmetadata>