summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-27 21:55:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 00:25:12 +0100
commit7ebcee0bb2258960da6d9559056bd689d0816c00 (patch)
treee42be35dc15c3c7ad35f4dcb3cd54a7c82864de7 /media-sound
parentnet-nntp/pan: stable 0.142 for hppa, bug #635938 (diff)
downloadgentoo-7ebcee0bb2258960da6d9559056bd689d0816c00.tar.gz
gentoo-7ebcee0bb2258960da6d9559056bd689d0816c00.tar.bz2
gentoo-7ebcee0bb2258960da6d9559056bd689d0816c00.zip
media-sound/teamspeak-client-bin: Prepare for dev-libs/quazip w/o qt4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild
new file mode 100644
index 000000000000..c9cb5a1fa0f8
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="https://www.teamspeak.com/"
+SRC_URI="
+ amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )"
+
+LICENSE="teamspeak3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio"
+
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+RDEPEND="
+ >=dev-libs/quazip-0.7.3[-qt4(-),qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[accessibility]
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ sys-libs/glibc
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Please download ${A}"
+ elog "from ${HOMEPAGE}?page=downloads and place this"
+ elog "file in ${DISTDIR}"
+}
+
+src_prepare() {
+ default
+
+ # Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807.
+ rm libQt* || die "Couldn't remove bundled Qt libraries."
+
+ rm -r platforms sqldrivers qt.conf || die "Couldn't remove bundle Qt files."
+
+ # Remove unwanted soundbackends.
+ if ! use alsa ; then
+ rm soundbackends/libalsa* || die
+ fi
+
+ if ! use pulseaudio ; then
+ rm soundbackends/libpulseaudio* || die
+ fi
+
+ # Remove quazip
+ rm libquazip.so || die
+
+ # Rename the tsclient to its shorter version, required by the teamspeak3 script we install.
+ mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version."
+}
+
+src_install() {
+ insinto /opt/teamspeak3-client
+ doins -r *
+
+ fperms +x /opt/teamspeak3-client/ts3client
+
+ dobin "${FILESDIR}/teamspeak3"
+
+ make_desktop_entry teamspeak3 TeamSpeak3 \
+ "/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \
+ Network
+}