summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-02-27 10:31:41 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:30:49 +0000
commit59021c0fed10204dc8ea7aaaca6b99b6d26e083e (patch)
treedb95fce43f72f06e2544819a673124d022201334 /media-sound
parentnet-wireless/blueman: Adapt to split pulseaudio metapackage (diff)
downloadgentoo-59021c0fed10204dc8ea7aaaca6b99b6d26e083e.tar.gz
gentoo-59021c0fed10204dc8ea7aaaca6b99b6d26e083e.tar.bz2
gentoo-59021c0fed10204dc8ea7aaaca6b99b6d26e083e.zip
media-sound/pulseaudio: Clean up split build IUSE and deps on meta.
Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24357 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild26
-rw-r--r--media-sound/pulseaudio/pulseaudio-15.99.1.ebuild40
2 files changed, 26 insertions, 40 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild b/media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild
new file mode 100644
index 000000000000..cd33ef88feb7
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+SRC_URI=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="metapackage"
+
+SLOT="0"
+
+IUSE="+daemon +glib"
+
+RDEPEND="
+ >=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
+ daemon? ( >=media-sound/pulseaudio-daemon-${PV} )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
diff --git a/media-sound/pulseaudio/pulseaudio-15.99.1.ebuild b/media-sound/pulseaudio/pulseaudio-15.99.1.ebuild
deleted file mode 100644
index 787bcfa92ef1..000000000000
--- a/media-sound/pulseaudio/pulseaudio-15.99.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit multilib-minimal
-
-DESCRIPTION="A networked sound server with an advanced plugin system"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
-SRC_URI=""
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="metapackage"
-
-SLOT="0"
-
-IUSE="+alsa +alsa-plugin bluetooth +daemon +glib jack zeroconf"
-
-# TODO: Get rid of the REQUIRED_USE by adapting the consumers to the splits with correct USE deps and dropping IUSE here
-REQUIRED_USE="
- !daemon? (
- !alsa
- !alsa-plugin
- !bluetooth
- !jack
- !zeroconf
- )
-"
-
-RDEPEND="
- >=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
- daemon? ( >=media-sound/pulseaudio-daemon-${PV}[alsa?,bluetooth?,jack?,zeroconf?] )
-"
-DEPEND="${RDEPEND}"
-# TODO: Figure out alsa-plugin handling, where pulseaudio-daemon isn't a multilib-minimal package
-PDEPEND="alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,${MULTILIB_USEDEP}] ) )"
-BDEPEND=""
-
-S="${WORKDIR}"