summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ripperx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ripperx')
-rw-r--r--media-sound/ripperx/Manifest1
-rw-r--r--media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch11
-rw-r--r--media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch10
-rw-r--r--media-sound/ripperx/metadata.xml8
-rw-r--r--media-sound/ripperx/ripperx-2.7.3.ebuild48
5 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/ripperx/Manifest b/media-sound/ripperx/Manifest
new file mode 100644
index 000000000000..5cd6e0e0962d
--- /dev/null
+++ b/media-sound/ripperx/Manifest
@@ -0,0 +1 @@
+DIST ripperX-2.7.3.tar.gz 536059 SHA256 7d58f95d9fc3b43890db4c09eafa3880e45880c9385524ce8786024fc5d2198c SHA512 fad4d8ee5e7ea37608b827230446f213c871d425920d0ffae5b0151e2270b36ca67156a78a530a3267141f8c5d0577a17647e4342468662472ea0f88bda69cea WHIRLPOOL 57a6acfad3e3e0701592f77a97980ad2db305c59e8cba4a28031c18e41bc4d67fef49534b2c7c8b469c9d036357dec077a20334c121e116cd36892dbd6295db7
diff --git a/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch b/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch
new file mode 100644
index 000000000000..11e18972e638
--- /dev/null
+++ b/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch
@@ -0,0 +1,11 @@
+--- plugins/Makefile.in
++++ plugins/Makefile.in
+@@ -658,7 +658,7 @@ uninstall-am: uninstall-binPROGRAMS
+ all: ripperX_plugin_tester $(PLUGINS)
+
+ .c.o:
+- $(CC) $(CFLAGS) $(LDFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch b/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch
new file mode 100644
index 000000000000..48c24f4054a9
--- /dev/null
+++ b/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch
@@ -0,0 +1,10 @@
+--- ripperX.pc.in
++++ ripperX.pc.in
+@@ -1,6 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
++includedir=@includedir@
+
+ pkglibdir=${libdir}/@PACKAGE@
+ pkgincludedir=${includedir}/@PACKAGE@
diff --git a/media-sound/ripperx/metadata.xml b/media-sound/ripperx/metadata.xml
new file mode 100644
index 000000000000..29910c778d39
--- /dev/null
+++ b/media-sound/ripperx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">ripperx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/ripperx/ripperx-2.7.3.ebuild b/media-sound/ripperx/ripperx-2.7.3.ebuild
new file mode 100644
index 000000000000..41c684320349
--- /dev/null
+++ b/media-sound/ripperx/ripperx-2.7.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_P=${P/x/X}
+MY_PN=${PN/x/X}
+
+DESCRIPTION="a GTK program to rip CD audio tracks and encode them to the Ogg, MP3, or FLAC formats"
+HOMEPAGE="http://sourceforge.net/projects/ripperx"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # AC_CHECK_LIB(m, ceilf, [], [MATH_LIB="-lm" MATH_LIB=""]) #401867
+ sed -i -e '/ripperX_LDADD/s:=:= -lm:' src/Makefile.in || die
+
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS CHANGES FAQ README* TODO
+ doicon src/xpms/${MY_PN}-icon.xpm
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}-icon
+}