summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-30 14:17:51 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-30 14:20:26 +0100
commitafb483297962f98d38ff20f01c3f7ee679c9fbf6 (patch)
tree9092875a1d7b6e80833609f48c458fb75d06cc4e /media-sound/musescore/files
parentmedia-sound/musescore: Remove 1.2 (diff)
downloadgentoo-afb483297962f98d38ff20f01c3f7ee679c9fbf6.tar.gz
gentoo-afb483297962f98d38ff20f01c3f7ee679c9fbf6.tar.bz2
gentoo-afb483297962f98d38ff20f01c3f7ee679c9fbf6.zip
media-sound/musescore: Remove 1.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound/musescore/files')
-rw-r--r--media-sound/musescore/files/musescore-1.3-cflags.patch113
-rw-r--r--media-sound/musescore/files/musescore-1.3-freetype251.patch19
2 files changed, 0 insertions, 132 deletions
diff --git a/media-sound/musescore/files/musescore-1.3-cflags.patch b/media-sound/musescore/files/musescore-1.3-cflags.patch
deleted file mode 100644
index 44af8851be97..000000000000
--- a/media-sound/musescore/files/musescore-1.3-cflags.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- mscore-1.3/mscore/al/CMakeLists.txt
-+++ mscore-1.3/mscore/al/CMakeLists.txt
-@@ -42,7 +42,7 @@
-
- set_source_files_properties(
- dsp.cpp xml.cpp tempo.cpp sig.cpp pos.cpp fraction.cpp
-- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- set_source_files_properties(dspSSE.cpp
---- mscore-1.3/mscore/awl/CMakeLists.txt
-+++ mscore-1.3/mscore/awl/CMakeLists.txt
-@@ -61,7 +61,7 @@
-
- set_target_properties( awl
- PROPERTIES COMPILE_FLAGS
-- "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- ADD_DEPENDENCIES(awl mops1)
---- mscore-1.3/mscore/CMakeLists.txt
-+++ mscore-1.3/mscore/CMakeLists.txt
-@@ -257,9 +257,6 @@
- WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
- )
-
--set(CMAKE_CXX_FLAGS_DEBUG "-g")
--set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
--
- if (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
- if (MINGW)
- set(FLAGS -DQT_DEBUG -DQT_DLL)
-@@ -272,9 +269,9 @@
- endif (MINGW)
- else (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
- if (MINGW)
-- set(FLAGS -O2 -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
-+ set(FLAGS -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
- else (MINGW)
-- set(FLAGS -O2 -DNDEBUG -DQT_NO_DEBUG)
-+ set(FLAGS -DNDEBUG -DQT_NO_DEBUG)
- endif (MINGW)
- endif (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
-
-@@ -284,7 +281,7 @@
- add_custom_command(
- OUTPUT ${PROJECT_BINARY_DIR}/all.h.gch
- COMMAND ${CMAKE_CXX_COMPILER}
-- -x c++-header -g ${FLAGS}
-+ -x c++-header ${FLAGS}
- -I${QT_HEADERS_DIR}
- -o all.h.gch all.h
- DEPENDS ${PROJECT_BINARY_DIR}/all.h
---- mscore-1.3/mscore/fluid/CMakeLists.txt
-+++ mscore-1.3/mscore/fluid/CMakeLists.txt
-@@ -28,7 +28,7 @@
- )
-
- set_target_properties( fluid
-- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- ADD_DEPENDENCIES(fluid mops1)
---- mscore-1.3/mscore/mscore/CMakeLists.txt
-+++ mscore-1.3/mscore/mscore/CMakeLists.txt
-@@ -199,7 +199,7 @@
- if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
- set_target_properties( mscore
- PROPERTIES
-- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
-+ COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
- LINK_FLAGS "${PROJECT_BINARY_DIR}/resfile.o -mwindows -mconsole -L ${CROSSQT}/lib"
- )
- else(CMAKE_BUILD_TYPE MATCHES "DEBUG")
---- mscore-1.3/mscore/ofqf/CMakeLists.txt
-+++ mscore-1.3/mscore/ofqf/CMakeLists.txt
-@@ -34,8 +34,8 @@
- )
-
- set_target_properties( ofqf
-- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- ADD_DEPENDENCIES(ofqf mops1)
--ADD_DEPENDENCIES(ofqf mops2)
-\ No newline at end of file
-+ADD_DEPENDENCIES(ofqf mops2)
---- mscore-1.3/mscore/osdabzip/CMakeLists.txt
-+++ mscore-1.3/mscore/osdabzip/CMakeLists.txt
-@@ -29,7 +29,7 @@
- )
-
- set_target_properties( osdabzip
-- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- ADD_DEPENDENCIES(osdabzip mops1)
---- mscore-1.3/mscore/singleapp/src/CMakeLists.txt
-+++ mscore-1.3/mscore/singleapp/src/CMakeLists.txt
-@@ -35,7 +35,7 @@
- )
-
- set_target_properties( qtsingleapp
-- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
-+ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
- )
-
- ADD_DEPENDENCIES(qtsingleapp mops1)
diff --git a/media-sound/musescore/files/musescore-1.3-freetype251.patch b/media-sound/musescore/files/musescore-1.3-freetype251.patch
deleted file mode 100644
index 0fbad400e8f9..000000000000
--- a/media-sound/musescore/files/musescore-1.3-freetype251.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Date: Tue, 15 Apr 2014 16:36:51 +0200
-Subject: [PATCH] Fix compilation with >=freetype-2.5.1 while remaining
- compatible with older freetype versions.
-
-This fixes Gentoo bug #507712 (https://bugs.gentoo.org/507712)
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-
---- mscore-1.3/mscore/mscore/genft.cpp
-+++ mscore-1.3/mscore/mscore/genft.cpp
-@@ -27,7 +27,7 @@
-
- #include <ft2build.h>
- #include FT_FREETYPE_H
--#include <freetype/tttables.h>
-+#include FT_TRUETYPE_TABLES_H
- #include "al/xml.h"
-
- QMap<int, int> codemap;