summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-15 11:26:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-15 11:26:22 +0200
commit2e773795961109f05266108fd0d746f64b784461 (patch)
tree1cfb00204cccc9f5de5ff1873a3fec2df62e112c /media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild
parentmedia-sound/mp3splt: Bump to 2.6.2 (diff)
downloadgentoo-2e773795961109f05266108fd0d746f64b784461.tar.gz
gentoo-2e773795961109f05266108fd0d746f64b784461.tar.bz2
gentoo-2e773795961109f05266108fd0d746f64b784461.zip
media-sound/mp3splt-gtk: Bump to 0.9.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild')
-rw-r--r--media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild b/media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild
new file mode 100644
index 000000000000..798d63469b34
--- /dev/null
+++ b/media-sound/mp3splt-gtk/mp3splt-gtk-0.9.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator autotools multilib
+
+DESCRIPTION="a GTK+ based utility to split mp3 and ogg files without decoding"
+HOMEPAGE="http://mp3splt.sourceforge.net"
+SRC_URI="mirror://sourceforge/mp3splt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="audacious doc gnome gstreamer nls"
+
+RDEPEND="~media-libs/libmp3splt-0.9.2
+ x11-libs/gtk+:3
+ audacious? ( >=media-sound/audacious-3.0 )
+ !audacious? ( dev-libs/dbus-glib )
+ gstreamer? ( media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0[mp3] )
+ gnome? ( gnome-base/libgnomeui )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome? ( app-text/gnome-doc-utils app-text/rarian )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ if use audacious; then
+ sed -i \
+ -e 's:@AUDACIOUS_LIBS@:-laudclient &:' \
+ src/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use nls || myconf+=" --disable-nls"
+ use audacious || myconf+=" --disable-audacious"
+ use gstreamer || myconf+=" --disable-gstreamer"
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable gnome) \
+ $(use_enable doc doxygen_doc) \
+ --disable-cutter \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README
+}