summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-22 19:19:05 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-22 19:21:59 +0100
commit2be3c70ec7cc258b6f9dbb7730f3ccde52632202 (patch)
treec4345c03b9113454e7b7c6063f2949d82c28da77 /media-sound/lollypop/lollypop-1.2.20.ebuild
parentapp-admin/kube-bench: 0.2.3 bump (diff)
downloadgentoo-2be3c70ec7cc258b6f9dbb7730f3ccde52632202.tar.gz
gentoo-2be3c70ec7cc258b6f9dbb7730f3ccde52632202.tar.bz2
gentoo-2be3c70ec7cc258b6f9dbb7730f3ccde52632202.zip
media-sound/lollypop: Version bump 1.2.20
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop/lollypop-1.2.20.ebuild')
-rw-r--r--media-sound/lollypop/lollypop-1.2.20.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/lollypop/lollypop-1.2.20.ebuild b/media-sound/lollypop/lollypop-1.2.20.ebuild
new file mode 100644
index 000000000000..0134d5693e9e
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.20.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_foreach_impl python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}