summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/id3v2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/id3v2')
-rw-r--r--media-sound/id3v2/Manifest1
-rw-r--r--media-sound/id3v2/files/id3v2-0.1.11-alpha.patch17
-rw-r--r--media-sound/id3v2/files/id3v2-0.1.11-makefile.patch23
-rw-r--r--media-sound/id3v2/id3v2-0.1.12.ebuild33
-rw-r--r--media-sound/id3v2/metadata.xml8
5 files changed, 82 insertions, 0 deletions
diff --git a/media-sound/id3v2/Manifest b/media-sound/id3v2/Manifest
new file mode 100644
index 000000000000..d0fa48bb1d89
--- /dev/null
+++ b/media-sound/id3v2/Manifest
@@ -0,0 +1 @@
+DIST id3v2-0.1.12.tar.gz 121476 SHA256 8105fad3189dbb0e4cb381862b4fa18744233c3bbe6def6f81ff64f5101722bf
diff --git a/media-sound/id3v2/files/id3v2-0.1.11-alpha.patch b/media-sound/id3v2/files/id3v2-0.1.11-alpha.patch
new file mode 100644
index 000000000000..9cad2ac3e8e0
--- /dev/null
+++ b/media-sound/id3v2/files/id3v2-0.1.11-alpha.patch
@@ -0,0 +1,17 @@
+Prevent a segfault on alpha and any other arch that doesn't always get
+zero-initialized automatics. Frankly the code in this segment looks
+pretty broken to me, but I'm just fixing the segfault...
+
+07 Feb 2004 agriffis
+
+--- id3v2.cpp 2004-05-04 20:30:15.000000000 +0200
++++ id3v2.cpp.alpha 2004-08-29 16:13:08.848513320 +0200
+@@ -423,7 +423,7 @@
+ {
+ // check if there is a total track number and if we only have
+ // the track number for this file. In this case combine them.
+- char *currentTrackNum, *newTrackNum;
++ char *currentTrackNum, *newTrackNum = NULL;
+
+ if (pFrame != NULL)
+ {
diff --git a/media-sound/id3v2/files/id3v2-0.1.11-makefile.patch b/media-sound/id3v2/files/id3v2-0.1.11-makefile.patch
new file mode 100644
index 000000000000..06a26a102b6c
--- /dev/null
+++ b/media-sound/id3v2/files/id3v2-0.1.11-makefile.patch
@@ -0,0 +1,23 @@
+Index: id3v2-0.1.11/Makefile
+===================================================================
+--- id3v2-0.1.11.orig/Makefile
++++ id3v2-0.1.11/Makefile
+@@ -3,14 +3,14 @@ all: id3v2
+ VERSION=0.1.11
+
+ PREFIX= /usr/local
+-CXXFLAGS+= -I${PREFIX}/include/ -DVERSION="\"${VERSION}\"" #-DSORT_RUNTIME
+-LDFLAGS+= -L${PREFIX}/lib/
++CXXFLAGS+= -I${PREFIX}/include/ -DVERSION="\"${VERSION}\"" $(OPT_CXXFLAGS) #-DSORT_RUNTIME
++LDFLAGS+= -L${PREFIX}/lib/ $(OPT_LDFLAGS)
+
+ id3v2: convert.o list.o id3v2.o genre.o
+- c++ ${LDFLAGS} -pedantic -Wall -lz -lid3 -g -o $@ $^
++ $(CXX) $(LDFLAGS) -pedantic -Wall -o $@ $^ -lz -lid3
+
+ create_map: create_map.o
+- c++ -Wall -g -o $@ $^
++ $(CXX) $(LDFLAGS) -o $@ $^
+
+ install: all
+ install -c -s id3v2 ${PREFIX}/bin/id3v2
diff --git a/media-sound/id3v2/id3v2-0.1.12.ebuild b/media-sound/id3v2/id3v2-0.1.12.ebuild
new file mode 100644
index 000000000000..601f65a677c9
--- /dev/null
+++ b/media-sound/id3v2/id3v2-0.1.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="A command line editor for id3v2 tags"
+HOMEPAGE="http://id3v2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/id3v2/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ emake clean || die
+}
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin id3v2 || die
+ doman id3v2.1 || die
+ dodoc README || die
+}
diff --git a/media-sound/id3v2/metadata.xml b/media-sound/id3v2/metadata.xml
new file mode 100644
index 000000000000..0fb660950983
--- /dev/null
+++ b/media-sound/id3v2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">id3v2</remote-id>
+ </upstream>
+</pkgmetadata>