summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-09-23 13:54:37 -0400
committerSam James <sam@gentoo.org>2023-09-23 20:38:18 +0100
commitebed4d88e0d42a34cf0090463f28b78f1702f593 (patch)
treeb37037ba5a5877f05c1f7cc3f2e6c2074eec48fd /media-sound/ardour
parentdev-util/mingw64-toolchain: fix build with libcxx-17 (diff)
downloadgentoo-ebed4d88e0d42a34cf0090463f28b78f1702f593.tar.gz
gentoo-ebed4d88e0d42a34cf0090463f28b78f1702f593.tar.bz2
gentoo-ebed4d88e0d42a34cf0090463f28b78f1702f593.zip
media-sound/ardour: Fix libc++ patch
Fix libc++ patch and remove from 9999. Upstream-PR: https://github.com/Ardour/ardour/pull/824 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/33012 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ardour-9999.ebuild1
-rw-r--r--media-sound/ardour/files/ardour-7.4-libc++.patch12
2 files changed, 6 insertions, 7 deletions
diff --git a/media-sound/ardour/ardour-9999.ebuild b/media-sound/ardour/ardour-9999.ebuild
index 029d71ed7696..6416faf2f9b8 100644
--- a/media-sound/ardour/ardour-9999.ebuild
+++ b/media-sound/ardour/ardour-9999.ebuild
@@ -73,7 +73,6 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-6.8-metadata.patch"
- "${FILESDIR}/${PN}-7.4-libc++.patch"
)
pkg_pretend() {
diff --git a/media-sound/ardour/files/ardour-7.4-libc++.patch b/media-sound/ardour/files/ardour-7.4-libc++.patch
index a596fafba0f7..44d8b2ccca47 100644
--- a/media-sound/ardour/files/ardour-7.4-libc++.patch
+++ b/media-sound/ardour/files/ardour-7.4-libc++.patch
@@ -13,9 +13,9 @@ Signed-off-by: Violet Purcell <vimproved@inventati.org>
#endif
#if SMTG_OS_LINUX
-+#if !defined (SMTG_USE_STDATOMIC_H)
++#if !defined (SMTG_USE_ATOMIC)
+#if defined (_LIBCPP_VERSION)
-+#define SMTG_USE_STDATOMIC_H 1
++#define SMTG_USE_ATOMIC 1
+#else
#include <ext/atomicity.h>
+#endif
@@ -26,8 +26,8 @@ Signed-off-by: Violet Purcell <vimproved@inventati.org>
#include <boost/uuid/uuid_generators.hpp>
#endif
-+#if defined (SMTG_USE_STDATOMIC_H) && SMTG_USE_STDATOMIC_H
-+#include <stdatomic.h>
++#if defined (SMTG_USE_ATOMIC) && SMTG_USE_ATOMIC
++#include <atomic>
+#endif
+
namespace Steinberg {
@@ -38,8 +38,8 @@ Signed-off-by: Violet Purcell <vimproved@inventati.org>
int32 PLUGIN_API atomicAdd (int32& var, int32 d)
{
-#if SMTG_OS_WINDOWS
-+#if SMTG_USE_STDATOMIC_H
-+ return atomic_fetch_add (reinterpret_cast<atomic_int_least32_t*> (&var), d) +d;
++#if SMTG_USE_ATOMIC
++ return atomic_fetch_add (reinterpret_cast<std::atomic_int_least32_t*> (&var), d) +d;
+#elif SMTG_OS_WINDOWS
return InterlockedExchangeAdd ((volatile long int*)&var, d) + d;
#elif SMTG_OS_MACOS