summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-07 14:48:55 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-07 15:05:10 +0100
commit787bab0fc8c1790bd22a9959e2a959e9a59d9565 (patch)
treedeff6a8d72cc034d78df7b55a0c8ae43159fa2c7 /media-radio
parentdev-util/yamllint: add 1.35.1 (diff)
downloadgentoo-787bab0fc8c1790bd22a9959e2a959e9a59d9565.tar.gz
gentoo-787bab0fc8c1790bd22a9959e2a959e9a59d9565.tar.bz2
gentoo-787bab0fc8c1790bd22a9959e2a959e9a59d9565.zip
media-radio/chirp: add 20240404
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/chirp/Manifest1
-rw-r--r--media-radio/chirp/chirp-20240404.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-radio/chirp/Manifest b/media-radio/chirp/Manifest
index 88e327f44d85..a1042ba87e35 100644
--- a/media-radio/chirp/Manifest
+++ b/media-radio/chirp/Manifest
@@ -1,3 +1,4 @@
DIST chirp-20231223.tar.gz 1850008 BLAKE2B b0d1d68889975d03c5b6a454d64e6fe9ac9f254423aaa77eff81d74cf3760cab8df0e9a411bab85c2ffaffde75ca515b72d7efdd5b9bdc0fc7b68eb5ef233e16 SHA512 5d8bf781d994e33c7de678b2ed31469f43dce9bebc99ee0d57b88ddf6eb41e23d8ec3e3bf5ef5ad4258f31dc47cb2748eeb290bceec38f0c859a9783259ff8d0
DIST chirp-20240217.tar.gz 1953875 BLAKE2B 50691cb74138831679c3fd764d35b2d19556ffd2865510d0072757bbf5b35ef92ec232a516e22f841a53ba886e151c4141ae14568237bd98275f8eefe5228497 SHA512 d25ee838eaef84ed31f10ecf0ee3eb786b0e2ee57059917e1da33f7b7a67e2b168fa13452b965d051b80792c7213fbecbabcc0e094845a434bd0d84b10522aa1
DIST chirp-20240311.tar.gz 1960895 BLAKE2B 843b68d15c82a437904554c25a6e810db1273753201903a086dde3c68481f2b2457f1aa36c96793ef6491febfbc6ec857180434d10f6eebd3e3ca4fde009c126 SHA512 f2fdc3479dc6605385d521314be6a3b8748e0bd9465d3e1ce70f0ff9fa9f9a459225101f6d42624e67ae6a8065aa89d8678bbbe666e55a57275b6327e9387083
+DIST chirp-20240404.tar.gz 1973257 BLAKE2B 566c0ed4ff9b0fe03bb1863e402b27b1b9a29c50b5467ca22bedf62e3b5584e82cde0c8cd430b92a223e0720e6b8c4ed5aa6b6632f660d7a01fc2f8dc7c78af9 SHA512 fc975eca574f2a230caeae7479675749b9d74340ebd7352069e4c51410b4c7c082f6fa3c027c499cdd58eed40479d1c4bfef75d29f2c4f809c88b4f8018f1feb
diff --git a/media-radio/chirp/chirp-20240404.ebuild b/media-radio/chirp/chirp-20240404.ebuild
new file mode 100644
index 000000000000..dc7a62cfbb52
--- /dev/null
+++ b/media-radio/chirp/chirp-20240404.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by wxpython
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A free, open-source tool for programming your radio"
+HOMEPAGE="https://chirpmyradio.com/"
+SRC_URI="https://archive.chirpmyradio.com/${PN}_next/next-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui radioreference"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ gui? (
+ dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+ dev-python/yattag[${PYTHON_USEDEP}]
+ )
+ radioreference? ( dev-python/suds-community[${PYTHON_USEDEP}] )
+')"
+BDEPEND="test? ( $(python_gen_cond_dep '
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+') )"
+
+distutils_enable_tests pytest
+
+# The alias map is an internal developer file not included in release tarballs.
+# Other disabled tests require Internet access.
+EPYTEST_DESELECT=(
+ tests/unit/test_directory.py::TestAliasMap
+ tests/unit/test_network_sources.py
+ tests/unit/test_repeaterbook.py
+)
+
+python_test() {
+ # From the contents of tests/ upstream currently only runs unit and driver
+ # tests, and the latter can take so long that they have even got a special
+ # script for only running them on drivers whose code has changed
+ # with respect to origin/master.
+ epytest tests/unit/
+}
+
+src_install() {
+ distutils-r1_src_install
+ if ! use gui; then
+ rm "${ED}"/usr/bin/${PN} || die
+ fi
+}