summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2019-11-15 22:29:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-11-17 09:45:46 +0200
commit528dafa8662eaf776e6d582e928a04dcc6b4e9e2 (patch)
treeed875a7a45caf4e9a5d4daf9266c365c42e0ce7b /media-plugins/vdr-dvbhddevice
parentx11-terms/terminology: bump to 1.6.0 (diff)
downloadgentoo-528dafa8662eaf776e6d582e928a04dcc6b4e9e2.tar.gz
gentoo-528dafa8662eaf776e6d582e928a04dcc6b4e9e2.tar.bz2
gentoo-528dafa8662eaf776e6d582e928a04dcc6b4e9e2.zip
media-plugins/vdr-dvbhddevice: fix gcc-9 compile issue
does not compile with gcc-9, fixed add a patch to fix it Closes: https://bugs.gentoo.org/693418 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-dvbhddevice')
-rw-r--r--media-plugins/vdr-dvbhddevice/files/convert-bool-fix.patch36
-rw-r--r--media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild14
2 files changed, 45 insertions, 5 deletions
diff --git a/media-plugins/vdr-dvbhddevice/files/convert-bool-fix.patch b/media-plugins/vdr-dvbhddevice/files/convert-bool-fix.patch
new file mode 100644
index 000000000000..0bdc79fba948
--- /dev/null
+++ b/media-plugins/vdr-dvbhddevice/files/convert-bool-fix.patch
@@ -0,0 +1,36 @@
+fix cannot convert bool to boolean wrt bug #693418
+
+Signed-of-by: Joerg Bornkessel <hd_brummy@astrali.de> (13 Nov 2019)
+diff -Naur powARman-dvbhddevice-2ea854ae8c7a.orig/dvbhdffdevice.c powARman-dvbhddevice-2ea854ae8c7a/dvbhdffdevice.c
+--- powARman-dvbhddevice-2ea854ae8c7a.orig/dvbhdffdevice.c 2019-11-13 18:46:50.000000000 +0100
++++ powARman-dvbhddevice-2ea854ae8c7a/dvbhdffdevice.c 2019-11-13 18:48:12.000000000 +0100
+@@ -1069,15 +1069,15 @@
+ }
+ else {
+ esyslog("ERROR: out of memory");
+- return false;
++ return FALSE;
+ }
+ if (jcd->mem) {
+ cinfo->dest->next_output_byte = jcd->mem + Used;
+ cinfo->dest->free_in_buffer = jcd->size - Used;
+- return true;
++ return TRUE;
+ }
+ }
+- return false;
++ return FALSE;
+ }
+
+ static void JpegCompressTermDestination(j_compress_ptr cinfo)
+@@ -1122,8 +1122,8 @@
+ cinfo.in_color_space = JCS_YCbCr;
+
+ jpeg_set_defaults(&cinfo);
+- jpeg_set_quality(&cinfo, Quality, true);
+- jpeg_start_compress(&cinfo, true);
++ jpeg_set_quality(&cinfo, Quality, TRUE);
++ jpeg_start_compress(&cinfo, TRUE);
+
+ int rs = Width * 3;
+ JSAMPROW rp[Height];
diff --git a/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild b/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild
index 9f21531f038a..67fe2ca2c87b 100644
--- a/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild
+++ b/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2018 Gentoo Authors
+# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,8 +8,7 @@ inherit vdr-plugin-2
HG_REVISION="2ea854ae8c7a"
HG_REVISION_DATE="20180420"
-DESCRIPTION="VDR Plugin: output device for the 'Full Featured' TechnoTrend
-S2-6400 DVB Card"
+DESCRIPTION="VDR Plugin: output device for the 'Full Featured' TechnoTrend S2-6400 DVB Card"
HOMEPAGE="https://bitbucket.org/powARman/dvbhddevice"
SRC_URI="https://bitbucket.org/powARman/dvbhddevice/get/${HG_REVISION}.tar.gz ->
${P}.tar.gz"
@@ -17,17 +16,22 @@ SRC_URI="https://bitbucket.org/powARman/dvbhddevice/get/${HG_REVISION}.tar.gz ->
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND=">=media-video/vdr-2.0.0"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/convert-bool-fix.patch"
+ "${FILESDIR}/define_AUDIO_GET_PTS.patch" )
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-dvbhddevice.*
+ usr/lib64/vdr/plugins/libvdr-dvbhddevice.*"
+
S="${WORKDIR}/powARman-${VDRPLUGIN}-${HG_REVISION}"
src_prepare() {
vdr-plugin-2_src_prepare
- eapply "${FILESDIR}/define_AUDIO_GET_PTS.patch"
fix_vdr_libsi_include dvbhdffdevice.c
}