summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/mediastreamer-ilbc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/mediastreamer-ilbc')
-rw-r--r--media-plugins/mediastreamer-ilbc/Manifest1
-rw-r--r--media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3.ebuild37
-rw-r--r--media-plugins/mediastreamer-ilbc/metadata.xml14
3 files changed, 52 insertions, 0 deletions
diff --git a/media-plugins/mediastreamer-ilbc/Manifest b/media-plugins/mediastreamer-ilbc/Manifest
new file mode 100644
index 000000000000..151f924702c1
--- /dev/null
+++ b/media-plugins/mediastreamer-ilbc/Manifest
@@ -0,0 +1 @@
+DIST msilbc-2.0.3.tar.gz 287297 SHA256 edd4da50715556141861f503ad5cef0f68a8868d4db53410413870c06e53be88 SHA512 ad2d37f272a413b401b8f2e38df75ac1e43bb70d7a03686f475a8c354a3d039293476e219fc5c629f30fe85bf717c7dd4251f508aa3f5871c6c5f22adeb6d1e9 WHIRLPOOL 278d97cd83e4a75b73ac92df9dc6fd90f79de6c19572435a761700257e42b44b1e29b8b9f15f84780510d752c1d5b19bf2f9b6fc50e68612688ca81c2419f944
diff --git a/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3.ebuild b/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3.ebuild
new file mode 100644
index 000000000000..cd8237b73821
--- /dev/null
+++ b/media-plugins/mediastreamer-ilbc/mediastreamer-ilbc-2.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_P="msilbc-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add iLBC support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="20ms-frames"
+
+RDEPEND="dev-libs/ilbc-rfc3951
+ >=media-libs/mediastreamer-2.0.0:="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # dev-libs/ilbc-rfc3951 does not ship pkgconfig .pc file,
+ # so these variables should be set here to satisfy configure
+ ILBC_CFLAGS="/usr/include" ILBC_LIBS="/usr/include -lilbc" \
+ econf \
+ $(use_enable 20ms-frames)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/media-plugins/mediastreamer-ilbc/metadata.xml b/media-plugins/mediastreamer-ilbc/metadata.xml
new file mode 100644
index 000000000000..bef02d10e7ca
--- /dev/null
+++ b/media-plugins/mediastreamer-ilbc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <use>
+ <flag name='20ms-frames'>enable 20ms frame size (default is 30ms). Some
+ VOIP providers such as Gizmo5 (aka Sipphone) require the codec to be
+ compiled with the 30ms setting.</flag>
+ </use>
+</pkgmetadata>
+