summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2024-09-04 22:02:14 +0300
committerMatt Turner <mattst88@gentoo.org>2024-09-04 15:46:05 -0400
commitf4e60367ba1fab9ab1f3323fc47a277506b409af (patch)
tree354fc7815ed5fa5bc65b5d5f0aec89b794aa6784 /media-libs
parentmedia-libs/mesa: remove dri3 meson build option (diff)
downloadgentoo-f4e60367ba1fab9ab1f3323fc47a277506b409af.tar.gz
gentoo-f4e60367ba1fab9ab1f3323fc47a277506b409af.tar.bz2
gentoo-f4e60367ba1fab9ab1f3323fc47a277506b409af.zip
media-libs/mesa: merge USE=vulkan and USE=vulkan-overlay
This commit removes USE=vulkan-overlay and enables the overlay by just toggling USE=vulkan, the former USE flag isn't needed, since the overlay has no additional dependencies. Closes: https://github.com/gentoo/gentoo/pull/38440 Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 2a22372153e4..172d1f066e10 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -60,7 +60,7 @@ IUSE="${IUSE_VIDEO_CARDS}
cpu_flags_x86_sse2 d3d9 debug +llvm
lm-sensors opencl +opengl osmesa +proprietary-codecs selinux
test unwind vaapi valgrind vdpau vulkan
- vulkan-overlay wayland +X xa +zstd"
+ wayland +X xa +zstd"
RESTRICT="!test? ( test )"
REQUIRED_USE="
d3d9? (
@@ -77,7 +77,6 @@ REQUIRED_USE="
)
)
llvm? ( ${LLVM_REQUIRED_USE} )
- vulkan-overlay? ( vulkan )
video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
@@ -413,6 +412,8 @@ multilib_src_configure() {
)
fi
fi
+
+ emesonargs+=(-Dvulkan-layers=device-select,overlay)
fi
driver_list() {
@@ -420,11 +421,6 @@ multilib_src_configure() {
echo "${drivers//$'\n'/,}"
}
- local vulkan_layers
- use vulkan && vulkan_layers+="device-select"
- use vulkan-overlay && vulkan_layers+=",overlay"
- emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
-
if use opengl && use X; then
emesonargs+=(-Dglx=dri)
else