summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 04:58:05 +0000
committerSam James <sam@gentoo.org>2024-02-29 04:59:40 +0000
commitc45685c99e64e88ed304071e598e98c1791550f0 (patch)
tree040caf8b34ef76da942d691c3ac1b89fb844e93f /media-libs
parentsci-biology/bwa: mark as LTO-unsafe (diff)
downloadgentoo-c45685c99e64e88ed304071e598e98c1791550f0.tar.gz
gentoo-c45685c99e64e88ed304071e598e98c1791550f0.tar.bz2
gentoo-c45685c99e64e88ed304071e598e98c1791550f0.zip
media-libs/exempi: add 2.6.5
re LTO: I haven't reported this upstream as the situation is complicated (exempi is a unix port of the adobe SDK). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/exempi/Manifest1
-rw-r--r--media-libs/exempi/exempi-2.6.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-libs/exempi/Manifest b/media-libs/exempi/Manifest
index aaabbef1cecc..8689e72934ec 100644
--- a/media-libs/exempi/Manifest
+++ b/media-libs/exempi/Manifest
@@ -1,3 +1,4 @@
DIST exempi-2.6.2.tar.bz2 3709476 BLAKE2B 3b65db1f9e7c2bf050af6e273b8327d70e23d3321d3c280ddf8b36b467e2822b12f93cb14d8d342e2a2974a9b745f13fd98c79d9b67e634da5bc9b5ae71e4918 SHA512 c81c7a5bad1a294ce253d1471c00740679b7fb489658ead68a6892b701cc02a031a5dc69d70045a8276e1e19c716df88e92014df4c2809266a71ff05de9ad57a
DIST exempi-2.6.3.tar.xz 2842408 BLAKE2B a3deb86a12161f4a1b7c0bacc4e6b59a5e54df4e5c158b48c8d66dc968e5fb1e210a9fac73e85720b43e9090c38a7023e771054e63a57c618385bb02a525d89e SHA512 517dba7534ac6978083338d3c3bf184c9b0a56e625e714703da71b064b68a8872bdd66673be27a192e7e6a22b9acd8eb1ad447c2a807f564547e765c63fbd2b4
DIST exempi-2.6.4.tar.xz 2843304 BLAKE2B 35ae01db243825eea05fe946a958be78ee75c3e6bc3cd02bf5596bd0c9543ccecb285c93e2533c7ceba1e42b25266834bddfd6eda4fef351b384298cc638cfb2 SHA512 86e41e24e34150f398dffe3219f1530fbf14606feeee9953395bfedb335316ec90ac88e2843f2c037a564909fc3cc82a5cce53edb18219663a1b454cda6bef72
+DIST exempi-2.6.5.tar.xz 2843132 BLAKE2B bc8c347af4c9c7bf085311ce055bd1c7cd5c2b845c723dd74bbcdf104be018885a82180333dbdda3cf9a64a4125dfe0fa0904fbd05663c3a6c32e6a60a8ca2d3 SHA512 71a0830c7a547bd7304e38f307a17a5ca70d6d22bb94db93f7e6c0903d1a1a1e211487cd530ec81fb058d0b45224018d23aab9a9394b6cfa025c50f0d77b5002
diff --git a/media-libs/exempi/exempi-2.6.5.ebuild b/media-libs/exempi/exempi-2.6.5.ebuild
new file mode 100644
index 000000000000..d11c41d688fd
--- /dev/null
+++ b/media-libs/exempi/exempi-2.6.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="2/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/boost )
+"
+BDEPEND="
+ dev-build/autoconf-archive
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for autoconf 2.71
+ config_rpath_update .
+ eautoreconf
+}
+
+src_configure() {
+ # ODR & SA violations
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ # - --enable-static as --disable-static breaks build
+ # - Valgrind detection is "disabled" due to bug #295875
+ econf \
+ --enable-static \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm samples/{,source,testfiles}/Makefile* || die
+ docinto examples
+ dodoc -r samples/.
+ fi
+
+ # --disable-static breaks tests
+ rm -rf "${ED}/usr/$(get_libdir)/libexempi.a" || die
+
+ find "${ED}" -name '*.la' -delete || die
+}