summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-21 10:08:45 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-21 10:09:47 +0200
commit89658b6de9b14449ae2df6d8c7be51100e265006 (patch)
tree94c54fba108ab8a10d53b1d420a1c8695c1ec970 /media-libs
parentmedia-libs/libheif: ebuild cleanups (diff)
downloadgentoo-89658b6de9b14449ae2df6d8c7be51100e265006.tar.gz
gentoo-89658b6de9b14449ae2df6d8c7be51100e265006.tar.bz2
gentoo-89658b6de9b14449ae2df6d8c7be51100e265006.zip
media-libs/libheif: Sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libheif/libheif-9999.ebuild59
1 files changed, 37 insertions, 22 deletions
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index 2b2d106acf2d..a4c096fce0e6 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools xdg multilib-minimal
+inherit cmake xdg multilib-minimal
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/strukturag/libheif.git"
@@ -17,14 +17,14 @@ DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
-SLOT="0/1.12"
-IUSE="+aom gdk-pixbuf go rav1e test +threads x265"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+aom gdk-pixbuf go rav1e svt-av1 test +threads x265"
REQUIRED_USE="test? ( go )"
RESTRICT="!test? ( test )"
BDEPEND="
test? (
- <dev-cpp/catch-3
+ dev-cpp/catch
dev-lang/go
)
"
@@ -32,53 +32,68 @@ DEPEND="
media-libs/dav1d:=[${MULTILIB_USEDEP}]
media-libs/libde265:=[${MULTILIB_USEDEP}]
media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/tiff:=[${MULTILIB_USEDEP}]
sys-libs/zlib:=[${MULTILIB_USEDEP}]
media-libs/libjpeg-turbo:0=[${MULTILIB_USEDEP}]
aom? ( >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}] )
gdk-pixbuf? ( x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}] )
go? ( dev-lang/go )
rav1e? ( media-video/rav1e:= )
+ svt-av1? ( media-libs/svt-av1[${MULTILIB_USEDEP}] )
x265? ( media-libs/x265:=[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libheif/heif_version.h
+)
+
src_prepare() {
default
- sed -i -e 's:-Werror::' configure.ac || die
-
if use test ; then
+ # bug 865351
rm tests/catch.hpp || die
ln -s "${ESYSROOT}"/usr/include/catch2/catch.hpp tests/catch.hpp || die
fi
- eautoreconf
+ cmake_src_prepare
- # prevent "stat heif-test.go: no such file or directory"
multilib_copy_sources
}
multilib_src_configure() {
export GO111MODULE=auto
- local econf_args=(
- --enable-libde265
- --disable-static
- $(multilib_is_native_abi && use go || echo --disable-go)
- $(use_enable aom)
- $(use_enable gdk-pixbuf)
- $(use_enable rav1e)
- $(use_enable threads multithreading)
- $(use_enable test tests)
- $(use_enable x265)
+ local mycmakeargs=(
+ -DENABLE_PLUGIN_LOADING=true
+ -DWITH_LIBDE265=true
+ -DWITH_AOM_DECODER=$(usex aom)
+ -DWITH_AOM_ENCODER=$(usex aom)
+ -DWITH_GDK_PIXBUF=$(usex gdk-pixbuf)
+ -DWITH_RAV1E="$(multilib_native_usex rav1e)"
+ -DWITH_SvtEnc="$(usex svt-av1)"
+ -DWITH_X265=$(usex x265)
+ -DWITH_KVAZAAR=true
+ -DWITH_JPEG_DECODER=true
+ -DWITH_JPEG_ENCODER=true
+ -DWITH_OpenJPEG_DECODER=true
+ -DWITH_OpenJPEG_ENCODER=true
)
- ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ default
+ cmake_src_compile
}
multilib_src_test() {
default
- emake -C go test
+}
+
+multilib_src_install() {
+ cmake_src_install
}
multilib_src_install_all() {
einstalldocs
- find "${ED}" -name '*.la' -delete || die
}