summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-08-13 20:36:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-08-13 20:37:46 +0100
commit2edf7c8d07255dc54c3b0ef1600776eaf4253e92 (patch)
tree81e379be37b0850acf12a69dcebb29ac2a41148e /media-libs
parentsys-boot/grub: simplify QA variables (diff)
downloadgentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.tar.gz
gentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.tar.bz2
gentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.zip
media-libs/hal-flash: Conversion to multilib, dependency fixes
The configure script is now included in the tarball. The patch to fix building outside of the source tree has been submitted upstream. Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/hal-flash/files/0001-Make-build-work-outside-of-source-tree.patch61
-rw-r--r--media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild34
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/hal-flash/files/0001-Make-build-work-outside-of-source-tree.patch b/media-libs/hal-flash/files/0001-Make-build-work-outside-of-source-tree.patch
new file mode 100644
index 000000000000..5896dc1872fc
--- /dev/null
+++ b/media-libs/hal-flash/files/0001-Make-build-work-outside-of-source-tree.patch
@@ -0,0 +1,61 @@
+From 82d4389c20f2b83dae49e15513834128f08d0264 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sat, 13 Aug 2016 15:35:38 +0100
+Subject: [PATCH] Make build work outside of source tree
+
+---
+ test/Makefile.am | 4 ++--
+ test/Makefile.in | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 83623d9..261197e 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -1,5 +1,5 @@
+ AM_CPPFLAGS = @DBUS_CFLAGS@
+-AM_CFLAGS = -std=gnu99 -I../src
++AM_CFLAGS = -std=gnu99 -I$(top_srcdir)/src
+ AM_LDFLAGS = @DBUS_LIBS@
+ LTVALGRIND = $(top_srcdir)/libtool --execute $(VALGRIND)
+
+@@ -8,7 +8,7 @@ TESTS_ENVIRONMENT = FLASH="$(LTVALGRIND) flash"
+
+ noinst_PROGRAMS = flash
+ flash_SOURCES = flash.c
+-flash_LDADD = ../src/libhal.la
++flash_LDADD = $(top_builddir)/src/libhal.la
+ flash_LDFLAGS = -static
+
+ clean-local :
+diff --git a/test/Makefile.in b/test/Makefile.in
+index cfd6c17..1417a9c 100644
+--- a/test/Makefile.in
++++ b/test/Makefile.in
+@@ -97,7 +97,7 @@ CONFIG_CLEAN_VPATH_FILES =
+ PROGRAMS = $(noinst_PROGRAMS)
+ am_flash_OBJECTS = flash.$(OBJEXT)
+ flash_OBJECTS = $(am_flash_OBJECTS)
+-flash_DEPENDENCIES = ../src/libhal.la
++flash_DEPENDENCIES = $(top_builddir)/src/libhal.la
+ AM_V_lt = $(am__v_lt_@AM_V@)
+ am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
+ am__v_lt_0 = --silent
+@@ -495,12 +495,12 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CPPFLAGS = @DBUS_CFLAGS@
+-AM_CFLAGS = -std=gnu99 -I../src
++AM_CFLAGS = -std=gnu99 -I$(top_srcdir)/src
+ AM_LDFLAGS = @DBUS_LIBS@
+ LTVALGRIND = $(top_srcdir)/libtool --execute $(VALGRIND)
+ TESTS_ENVIRONMENT = FLASH="$(LTVALGRIND) flash"
+ flash_SOURCES = flash.c
+-flash_LDADD = ../src/libhal.la
++flash_LDADD = $(top_builddir)/src/libhal.la
+ flash_LDFLAGS = -static
+ all: all-am
+
+--
+2.8.2
+
diff --git a/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild b/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..ae2499bafb74
--- /dev/null
+++ b/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="libhal stub forwarding to UDisks for Adobe Flash to play DRM content"
+HOMEPAGE="https://github.com/cshorler/hal-flash http://build.opensuse.org/package/show/devel:openSUSE:Factory/hal-flash"
+SRC_URI="http://github.com/cshorler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-libs/glib:2=[${MULTILIB_USEDEP},dbus]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ !sys-apps/hal"
+
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+ECONF_SOURCE="${S}"
+DOCS="FAQ.txt README"
+PATCHES=( "${FILESDIR}"/0001-Make-build-work-outside-of-source-tree.patch )
+
+src_install() {
+ multilib-minimal_src_install
+ prune_libtool_files
+}