summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-14 18:21:18 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-14 18:21:18 +0100
commitc615988140e0113f4b67b63de779db93c22d43f0 (patch)
tree29e2efe6190de9b43aeabf46bf7edefabe167eb5 /media-libs/slv2
parentmedia-libs/slv2-0.6.6-r2: fixed configuration against new lv2 (diff)
downloadgentoo-c615988140e0113f4b67b63de779db93c22d43f0.tar.gz
gentoo-c615988140e0113f4b67b63de779db93c22d43f0.tar.bz2
gentoo-c615988140e0113f4b67b63de779db93c22d43f0.zip
media-libs/slv2-0.6.6-r3: some fixes
1) updated to eapi6 2) organized deps 3) added patch for partial migration to python3 4) rebased ldconfig.patch Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/slv2')
-rw-r--r--media-libs/slv2/files/ldconfig.patch12
-rw-r--r--media-libs/slv2/files/slv2-0.6.6-python3.patch22
-rw-r--r--media-libs/slv2/slv2-0.6.6-r3.ebuild52
3 files changed, 80 insertions, 6 deletions
diff --git a/media-libs/slv2/files/ldconfig.patch b/media-libs/slv2/files/ldconfig.patch
index f53ff9e7df59..ea0492bd1d3a 100644
--- a/media-libs/slv2/files/ldconfig.patch
+++ b/media-libs/slv2/files/ldconfig.patch
@@ -1,9 +1,9 @@
-Index: slv2-0.6.2/autowaf.py
-===================================================================
---- slv2-0.6.2.orig/autowaf.py
-+++ slv2-0.6.2/autowaf.py
-@@ -324,8 +324,5 @@ def build_dox(bld, name, version, srcdir
- out1.command_is_external = True
+diff --git a/autowaf.py b/autowaf.py
+index 4797ea3..f32f994 100644
+--- a/autowaf.py
++++ b/autowaf.py
+@@ -375,8 +375,5 @@ def build_version_files(header_path, source_path, domain, major, minor, micro):
+ return None
def shutdown():
- # This isn't really correct (for packaging), but people asking is annoying
diff --git a/media-libs/slv2/files/slv2-0.6.6-python3.patch b/media-libs/slv2/files/slv2-0.6.6-python3.patch
new file mode 100644
index 000000000000..651c761d988c
--- /dev/null
+++ b/media-libs/slv2/files/slv2-0.6.6-python3.patch
@@ -0,0 +1,22 @@
+diff --git a/autowaf.py b/autowaf.py
+index 4797ea3..90db9be 100644
+--- a/autowaf.py
++++ b/autowaf.py
+@@ -354,7 +354,7 @@ def build_version_files(header_path, source_path, domain, major, minor, micro):
+ o.write(text)
+ o.close()
+ except IOError:
+- print "Could not open", source_path, " for writing\n"
++ print("Could not open", source_path, " for writing\n")
+ sys.exit(-1)
+
+ text = "#ifndef __" + domain + "_version_h__\n"
+@@ -369,7 +369,7 @@ def build_version_files(header_path, source_path, domain, major, minor, micro):
+ o.write(text)
+ o.close()
+ except IOError:
+- print "Could not open", header_path, " for writing\n"
++ print("Could not open", header_path, " for writing\n")
+ sys.exit(-1)
+
+ return None
diff --git a/media-libs/slv2/slv2-0.6.6-r3.ebuild b/media-libs/slv2/slv2-0.6.6-r3.ebuild
new file mode 100644
index 000000000000..24cd431efebd
--- /dev/null
+++ b/media-libs/slv2/slv2-0.6.6-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+inherit eutils multilib python-any-r1 toolchain-funcs waf-utils
+
+DESCRIPTION="A library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://wiki.drobilla.net/SLV2"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc jack"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+CDEPEND="
+ >=dev-libs/redland-1.0.6
+ jack? ( virtual/jack )
+ media-libs/lv2
+"
+RDEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/ldconfig.patch
+ "${FILESDIR}"/${P}-raptor2-link.patch
+ "${FILESDIR}"/${P}-python3.patch
+)
+
+src_prepare() {
+ default
+ has_version ">=media-libs/lv2-1.16.0" && (sed -i "s/lv2core/lv2/" wscript || die "Failed to fix lv2")
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use doc && echo --build-docs) \
+ $(use jack || echo --no-jack)
+}