summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/silgraphite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/silgraphite')
-rw-r--r--media-libs/silgraphite/Manifest1
-rw-r--r--media-libs/silgraphite/files/silgraphite-2.3.1-aligned_access.patch63
-rw-r--r--media-libs/silgraphite/metadata.xml11
-rw-r--r--media-libs/silgraphite/silgraphite-2.3.1.ebuild45
4 files changed, 120 insertions, 0 deletions
diff --git a/media-libs/silgraphite/Manifest b/media-libs/silgraphite/Manifest
new file mode 100644
index 000000000000..069bc42cd28d
--- /dev/null
+++ b/media-libs/silgraphite/Manifest
@@ -0,0 +1 @@
+DIST silgraphite-2.3.1.tar.gz 3239482 SHA256 9b07c6e91108b1fa87411af4a57e25522784cfea0deb79b34ced608444f2ed65 SHA512 6b0fa29e0ee507da17509ed6374b64d51360b3012bba512785186348c153047c2e6f28114e36d133f3c05dd319919bd79e9ed97fc9e29ad6bf2f7a032eb22df2 WHIRLPOOL fd49e74303f22a58e04d9792d17ec80f33c2c357d4377df851e526a7d5e7858fb4d3cca31654f37bf8016697709001625b1d54063fd1db60eb3ff68eea7f9bb7
diff --git a/media-libs/silgraphite/files/silgraphite-2.3.1-aligned_access.patch b/media-libs/silgraphite/files/silgraphite-2.3.1-aligned_access.patch
new file mode 100644
index 000000000000..ee5c1702e92e
--- /dev/null
+++ b/media-libs/silgraphite/files/silgraphite-2.3.1-aligned_access.patch
@@ -0,0 +1,63 @@
+Fix unaligned reads.
+https://bugs.gentoo.org/show_bug.cgi?id=304921
+
+Upstream:
+https://sourceforge.net/tracker/?func=detail&aid=2995413&group_id=66144&atid=513479
+
+Index: silgraphite-2.3.1/engine/src/segment/FileInput.cpp
+===================================================================
+--- silgraphite-2.3.1.orig/engine/src/segment/FileInput.cpp
++++ silgraphite-2.3.1/engine/src/segment/FileInput.cpp
+@@ -41,6 +41,10 @@ DEFINE_THIS_FILE
+
+ //:End Ignore
+
++#define RAW_READ(var,size,buf) \
++ for(int i = 0; i < isizeof(size);i++){\
++ var |= buf[i]<<8*(isizeof(size)-i-1);\
++ }
+ //:>********************************************************************************************
+ //:> Forward declarations
+ //:>********************************************************************************************
+@@ -133,11 +137,11 @@ byte GrBufferIStream::ReadByteFromFont()
+ ----------------------------------------------------------------------------------------------*/
+ short GrBufferIStream::ReadShortFromFont()
+ {
+- short snInput = *(short *)m_pbNext;
++ short snInput = 0;
++ RAW_READ(snInput,short,m_pbNext);
+ m_pbNext += isizeof(short);
+ if (m_pbLim && m_pbNext > m_pbLim)
+ THROW(kresReadFault);
+- snInput = lsbf(snInput);
+ return snInput;
+ }
+
+@@ -147,11 +151,11 @@ short GrBufferIStream::ReadShortFromFont
+ ----------------------------------------------------------------------------------------------*/
+ utf16 GrBufferIStream::ReadUShortFromFont()
+ {
+- utf16 chwInput = *(utf16 *)m_pbNext;
++ utf16 chwInput = 0;
++ RAW_READ(chwInput,utf16,m_pbNext);
+ m_pbNext += isizeof(utf16);
+ if (m_pbLim && m_pbNext > m_pbLim)
+ THROW(kresReadFault);
+- chwInput = lsbf(chwInput);
+ return chwInput;
+ }
+
+@@ -161,11 +165,11 @@ utf16 GrBufferIStream::ReadUShortFromFon
+ ----------------------------------------------------------------------------------------------*/
+ int GrBufferIStream::ReadIntFromFont()
+ {
+- int nInput = *(int *)m_pbNext;
++ int nInput = 0;
++ RAW_READ(nInput,int,m_pbNext);
+ m_pbNext += isizeof(int);
+ if (m_pbLim && m_pbNext > m_pbLim)
+ THROW(kresReadFault);
+- nInput = lsbf(nInput);
+ return nInput;
+ }
+
diff --git a/media-libs/silgraphite/metadata.xml b/media-libs/silgraphite/metadata.xml
new file mode 100644
index 000000000000..07d4510f8b76
--- /dev/null
+++ b/media-libs/silgraphite/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <use>
+ <flag name="pango">Enables the pango-graphite pango module.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">silgraphite</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/silgraphite/silgraphite-2.3.1.ebuild b/media-libs/silgraphite/silgraphite-2.3.1.ebuild
new file mode 100644
index 000000000000..e354e7768fbd
--- /dev/null
+++ b/media-libs/silgraphite/silgraphite-2.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Rendering engine for complex non-Roman writing systems"
+HOMEPAGE="http://graphite.sil.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pango static-libs truetype xft"
+
+RDEPEND="
+ pango? ( x11-libs/pango media-libs/fontconfig )
+ truetype? ( media-libs/freetype:2 )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-aligned_access.patch"
+
+ # Drop DEPRECATED flags, bug #385533
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ wrappers/pangographite/Makefile.am wrappers/pangographite/Makefile.in \
+ wrappers/pangographite/graphite/Makefile.am || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with xft) \
+ $(use_with truetype freetype) \
+ $(use_with pango pangographite)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}