summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/rtaudio/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/rtaudio/files')
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch24
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch73
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch16
3 files changed, 113 insertions, 0 deletions
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
new file mode 100644
index 000000000000..9fa657929c21
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
@@ -0,0 +1,24 @@
+--- rtaudio-4.0.11/configure.ac
++++ rtaudio-4.0.11/configure.ac
+@@ -23,8 +23,8 @@
+ AC_MSG_CHECKING(whether to compile debug version)
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug = enable various debug output],
+- [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( cxxflag, [-g] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
+- [AC_SUBST( cppflag, [] ) AC_SUBST( cxxflag, [-O2] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
++ [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
++ [AC_SUBST( cppflag, [] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
+
+
+ # Checks for functions
+@@ -33,10 +33,6 @@
+ # For -I and -D flags
+ CPPFLAGS="$CPPFLAGS $cppflag"
+
+-# For debugging and optimization ... overwrite default because it has both -g and -O2
+-#CXXFLAGS="$CXXFLAGS $cxxflag"
+-CXXFLAGS="$cxxflag"
+-
+ # Check compiler and use -Wall if gnu.
+ if [test $GXX = "yes" ;] then
+ AC_SUBST( cxxflag, [-Wall] )
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch b/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch
new file mode 100644
index 000000000000..7680f75d40d3
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.12-configure.patch
@@ -0,0 +1,73 @@
+--- rtaudio-4.0.12/configure.ac
++++ rtaudio-4.0.12/configure.ac
+@@ -25,9 +25,9 @@
+ AC_PROG_CXX(g++ CC c++ cxx)
+ AC_PROG_RANLIB
+ AC_PATH_PROG(AR, ar, no)
+-if [[ $AR = "no" ]] ; then
+- AC_MSG_ERROR("Could not find ar - needed to create a library");
+-fi
++AS_IF([test "x$AR" == "x" ], [
++ AC_MSG_ERROR("Could not find ar - needed to create a library")
++])
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -83,39 +83,46 @@
+ ;;
+
+ *-*-linux*)
+- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
++ AC_ARG_WITH([jack], AS_HELP_STRING([--with-jack], [choose JACK server support (mac and linux only)]))
++
++ AS_IF([test "x$with_jack" != "xno"], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))])
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ AC_ARG_WITH([alsa], AS_HELP_STRING([--with-alsa], [choose native ALSA API support (linux only)]))
++
++ AS_IF([test "x$with_alsa" != "xno"], [
+ api="$api -D__LINUX_ALSA__"
+ req="$req alsa"
+ AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ # Look for PULSE flag
+- AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio API support (linux only)], [
++ AC_ARG_WITH([pulse], AS_HELP_STRING([--with-pulse], [choose PulseAudio API support (linux only)]))
++
++ AS_IF([test "x$with_pulse" != "xno"], [
+ api="$api -D__LINUX_PULSE__"
+ req="$req libpulse-simple"
+ AC_MSG_RESULT(using PulseAudio)
+ PKG_CHECK_MODULES([PULSE], [libpulse-simple], , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))
+- LIBS="$LIBS `pkg-config --libs libpulse-simple`" ], )
++ LIBS="$LIBS `pkg-config --libs libpulse-simple`" ])
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ AC_ARG_WITH([oss], AS_HELP_STRING([--with-oss], [choose OSS API support (linux only)]))
++
++ AS_IF([test "x$with_oss" != "xno"], [
+ api="$api -D__LINUX_OSS__"
+- AC_MSG_RESULT(using OSS)], )
++ AC_MSG_RESULT(using OSS)])
+
+ # If no audio api flags specified, use ALSA
+- if [test "$api" == "";] then
++ AS_IF([test "x$api" == "x"], [
+ AC_MSG_RESULT(using ALSA)
+ AC_SUBST( api, [-D__LINUX_ALSA__] )
+ req="$req alsa"
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
+- fi
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))])
+
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
+ ;;
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch b/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch
new file mode 100644
index 000000000000..adf109de5de9
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.12-makefile.patch
@@ -0,0 +1,16 @@
+--- rtaudio-4.0.12/Makefile.in
++++ rtaudio-4.0.12/Makefile.in
+@@ -24,9 +24,11 @@
+ tests:
+ cd tests && $(MAKE) all
+
+-$(LIBRARIES): $(OBJECTS)
++$(STATIC): $(OBJECTS)
+ $(AR) ruv $(STATIC) $(OBJECTS)
+- ranlib $(STATIC)
++ $(RANLIB) $(STATIC)
++
++$(SHARED): $(OBJECTS)
+ $(CC) -fPIC @libflags@ $(OBJECTS) @LIBS@
+ $(LN) -sf @sharedname@ $(SHARED)
+ $(LN) -sf @sharedname@ $(SHARED).$(MAJOR)