summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-02-19 17:58:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-27 15:12:53 +0200
commitdf14e89f539416d602ac7c543215dca5a4e16aa6 (patch)
tree06be0dd2d2c4aed76effa83fdf27b4d73e8f9171 /media-libs/ptex
parentdev-libs/ayatana-ido: add 0.9.3 (diff)
downloadgentoo-df14e89f539416d602ac7c543215dca5a4e16aa6.tar.gz
gentoo-df14e89f539416d602ac7c543215dca5a4e16aa6.tar.bz2
gentoo-df14e89f539416d602ac7c543215dca5a4e16aa6.zip
media-libs/ptex: add 2.4.2
Closes: https://bugs.gentoo.org/895442 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/29667 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/ptex')
-rw-r--r--media-libs/ptex/Manifest1
-rw-r--r--media-libs/ptex/metadata.xml4
-rw-r--r--media-libs/ptex/ptex-2.4.2.ebuild37
3 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/ptex/Manifest b/media-libs/ptex/Manifest
index 185404267ba5..8442a8fa3c7f 100644
--- a/media-libs/ptex/Manifest
+++ b/media-libs/ptex/Manifest
@@ -1 +1,2 @@
DIST ptex-2.3.2.tar.gz 308550 BLAKE2B 7b3145dbf9d2c13140c3f20ed606ee911deed3c38fd30adfbb01b58c3af5794dbd4e0fa1fbab6e8ae83556a0ffec725bf077271abf752f1271ed721ca200a1ff SHA512 dbc557dc5e1761204ee3483af9bf4ff1504cbd7955e0405dc27a51f7182e2445e41db086b2792c2491aa2cbaddc74e523170a4b3d25e44d332123d5b7081f4b9
+DIST ptex-2.4.2.tar.gz 312942 BLAKE2B 13446eae2327f92410859f7e01dc30e46a069d2069b2b1bf1bd9fe52902efacb6aeadc2c3bdc66dfad17662e01ae6fd3fac2861674691646871721d9e12ceb12 SHA512 3b9607b7803e7c857bb00a6d4d8bbe108810c622a3593fb5d655183f3e6689f274ee5e79bcaab6928de38daf05cf25eb56125f39477f134131a8ad45071551b3
diff --git a/media-libs/ptex/metadata.xml b/media-libs/ptex/metadata.xml
index d644ef1fd59f..0b9a4bd455e6 100644
--- a/media-libs/ptex/metadata.xml
+++ b/media-libs/ptex/metadata.xml
@@ -5,6 +5,10 @@
<email>agrigo2001@yahoo.com.au</email>
<name>Adrian Grigo</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>waebbl-gentoo@posteo.net</email>
+ <name>Bernd Waibel</name>
+ </maintainer>
<maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
diff --git a/media-libs/ptex/ptex-2.4.2.ebuild b/media-libs/ptex/ptex-2.4.2.ebuild
new file mode 100644
index 000000000000..a8b095d5b9f7
--- /dev/null
+++ b/media-libs/ptex/ptex-2.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="https://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/doxygen"
+
+RESTRICT="test"
+
+src_prepare() {
+ # https://github.com/wdas/ptex/issues/41
+ cat <<-EOF > version || die
+ v${PV}
+ EOF
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
+ -DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
+ )
+ cmake_src_configure
+}