summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-10 19:08:29 -0300
committerJoonas Niilola <juippis@gentoo.org>2024-08-27 09:47:56 +0300
commitd9f4fc888042b8eb9d45b9ac67df16cd3a117c85 (patch)
treecc98a99522cd6b608cd01244b22be7433c4cd552 /media-libs/libheif/libheif-1.18.2.ebuild
parentmedia-gfx/entice: stabilize 0.0.1 for amd64 (diff)
downloadgentoo-d9f4fc888042b8eb9d45b9ac67df16cd3a117c85.tar.gz
gentoo-d9f4fc888042b8eb9d45b9ac67df16cd3a117c85.tar.bz2
gentoo-d9f4fc888042b8eb9d45b9ac67df16cd3a117c85.zip
media-libs/libheif: Bump to 1.18.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38075 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/libheif/libheif-1.18.2.ebuild')
-rw-r--r--media-libs/libheif/libheif-1.18.2.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/libheif/libheif-1.18.2.ebuild b/media-libs/libheif/libheif-1.18.2.ebuild
new file mode 100644
index 000000000000..33800f5b64c3
--- /dev/null
+++ b/media-libs/libheif/libheif-1.18.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/libheif.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/libheif/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+aom gdk-pixbuf go rav1e svt-av1 test +threads x265"
+REQUIRED_USE="test? ( go )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-cpp/catch
+ dev-lang/go
+ )
+"
+DEPEND="
+ media-libs/dav1d:=[${MULTILIB_USEDEP}]
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/tiff:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ media-libs/libjpeg-turbo:0=[${MULTILIB_USEDEP}]
+ aom? ( >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}] )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}] )
+ go? ( dev-lang/go )
+ rav1e? ( media-video/rav1e:= )
+ svt-av1? ( media-libs/svt-av1[${MULTILIB_USEDEP}] )
+ x265? ( media-libs/x265:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libheif/heif_version.h
+)
+
+src_prepare() {
+ if use test ; then
+ # bug 865351
+ rm tests/catch.hpp || die
+ ln -s "${ESYSROOT}"/usr/include/catch2/catch.hpp tests/catch.hpp || die
+ fi
+
+ cmake_src_prepare
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export GO111MODULE=auto
+ local mycmakeargs=(
+ -DENABLE_PLUGIN_LOADING=true
+ -DWITH_LIBDE265=true
+ -DWITH_AOM_DECODER=$(usex aom)
+ -DWITH_AOM_ENCODER=$(usex aom)
+ -DWITH_GDK_PIXBUF=$(usex gdk-pixbuf)
+ -DWITH_RAV1E="$(multilib_native_usex rav1e)"
+ -DWITH_SvtEnc="$(usex svt-av1)"
+ -DWITH_X265=$(usex x265)
+ -DWITH_KVAZAAR=true
+ -DWITH_JPEG_DECODER=true
+ -DWITH_JPEG_ENCODER=true
+ -DWITH_OpenJPEG_DECODER=true
+ -DWITH_OpenJPEG_ENCODER=true
+ )
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ default
+ cmake_src_compile
+}
+
+multilib_src_test() {
+ default
+}
+
+multilib_src_install() {
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}