summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-01-16 20:41:01 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:28 +0100
commit1be2c77cc426f3b0c436454a2ff0620e2e63c5aa (patch)
tree28d5a613b5979f2953d3108535eb4f1e55a9df77 /media-libs/libbsb
parentdev-util/hxd: EAPI8 bump, fix HOMEPAGE, LICENSE (diff)
downloadgentoo-1be2c77cc426f3b0c436454a2ff0620e2e63c5aa.tar.gz
gentoo-1be2c77cc426f3b0c436454a2ff0620e2e63c5aa.tar.bz2
gentoo-1be2c77cc426f3b0c436454a2ff0620e2e63c5aa.zip
media-libs/libbsb: EAPI8 bump, fix bug #724744
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/724744 Closes: https://bugs.gentoo.org/899814 Closes: https://github.com/gentoo/gentoo/pull/34842 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-libs/libbsb')
-rw-r--r--media-libs/libbsb/libbsb-0.0.7-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libbsb/libbsb-0.0.7-r2.ebuild b/media-libs/libbsb/libbsb-0.0.7-r2.ebuild
new file mode 100644
index 000000000000..be7212a192b1
--- /dev/null
+++ b/media-libs/libbsb/libbsb-0.0.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Portable C library for reading and writing BSB format image files"
+HOMEPAGE="https://libbsb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libpng
+ media-libs/tiff:="
+RDEPEND="${DEPEND}"
+
+# "make check" in 0.0.7 fails with newer tiff versions (4.0.0) altough the
+# tools work perfectly, so restrict test until this is fixed upstream
+RESTRICT="test"
+
+src_prepare(){
+ sed -i -e "s|ar crv|$(tc-getAR) crv|" Makefile.am || die
+ default
+ eautoreconf
+}