summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-09 10:01:00 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-09 12:08:12 +0200
commite1b4c3f14c2484ec20c4d83b2962b25c358e6bcb (patch)
tree08fbff39c438222b965992ecd16345c9394c0f65 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild
parentmedia-plugins/gst-plugins-soup: Version bump (diff)
downloadgentoo-e1b4c3f14c2484ec20c4d83b2962b25c358e6bcb.tar.gz
gentoo-e1b4c3f14c2484ec20c4d83b2962b25c358e6bcb.tar.bz2
gentoo-e1b4c3f14c2484ec20c4d83b2962b25c358e6bcb.zip
media-libs/gst-plugins-ugly: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild
new file mode 100644
index 000000000000..873fa518178a
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}