summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-03-18 12:33:48 +0200
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:31 +0300
commit21722cccb219dfc528fabdbc63f5b43cd4bf95b2 (patch)
tree0e581ad850b9e1db59a0ead4a6babce81e110057 /media-libs/gst-plugins-good
parentgstreamer-meson.eclass: Avoid ximagesrc and v4l2 getting enabled for -good sp... (diff)
downloadgentoo-21722cccb219dfc528fabdbc63f5b43cd4bf95b2.tar.gz
gentoo-21722cccb219dfc528fabdbc63f5b43cd4bf95b2.tar.bz2
gentoo-21722cccb219dfc528fabdbc63f5b43cd4bf95b2.zip
media-libs/gst-plugins-good: ebuild cleanups
Now that eclass correctly treats v4l2 and ximagesrc as ext plugins (and qt5/qt6 from much earlier additions), we don't need to explicitly disable them in the ebuild as well anymore. The extra ximagesrc options are also not necessary to pass, as only the ximagesrc build dir meson.build looks at them and doesn't evaluate it at all when ximagesrc itself is disabled. Also drop legacy pre-meson multilib_src_install_all leftover that is unnecessary due to just dealing with libtool remnants that aren't there since meson in the first place. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.22.10.ebuild20
1 files changed, 1 insertions, 19 deletions
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.22.10.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.22.10.ebuild
index 69efc3d2564f..bbddb2d85876 100644
--- a/media-libs/gst-plugins-good/gst-plugins-good-1.22.10.ebuild
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.22.10.ebuild
@@ -29,30 +29,12 @@ DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
PATCHES=( "${FILESDIR}/gst-plugins-good-1.22.9-soup-tests-automagic.patch" )
multilib_src_configure() {
+ # gst/matroska can use bzip2
GST_PLUGINS_NOAUTO="bz2"
local emesonargs=(
-Dbz2=enabled
-
- # gst-plugins-ximagesrc
- -Dximagesrc=disabled
- -Dximagesrc-xshm=disabled
- -Dximagesrc-xfixes=disabled
- -Dximagesrc-xdamage=disabled
-
- # gst-plugins-v4l2
- -Dv4l2=disabled
-
- # TODO: These two almost certainly need to be their own
- # gst-plugins-qt5 & qt-plugins-qt6.
- -Dqt5=disabled
- -Dqt6=disabled
)
gstreamer_multilib_src_configure
}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}