summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/yafaray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/yafaray')
-rw-r--r--media-gfx/yafaray/Manifest2
-rw-r--r--media-gfx/yafaray/metadata.xml13
-rw-r--r--media-gfx/yafaray/yafaray-0.1.1.ebuild85
3 files changed, 100 insertions, 0 deletions
diff --git a/media-gfx/yafaray/Manifest b/media-gfx/yafaray/Manifest
new file mode 100644
index 000000000000..663742b976f0
--- /dev/null
+++ b/media-gfx/yafaray/Manifest
@@ -0,0 +1,2 @@
+DIST YafaRay-blender.0.1.1.zip 37965 SHA256 68041b4c13793c0ef3491dc5ccb3e39ae3f845b9c6f9edadddd3cd71a83abdad
+DIST YafaRay.0.1.1.zip 542063 SHA256 9588f1ee85fae286fcfc0bd6d05fb2c60bfadea0c6f4254fb6dac00a36f7f3a1
diff --git a/media-gfx/yafaray/metadata.xml b/media-gfx/yafaray/metadata.xml
new file mode 100644
index 000000000000..3ec6e16295f6
--- /dev/null
+++ b/media-gfx/yafaray/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<longdescription lang="en">
+YafaRay is a raytracing open source render engine. Raytracing is a rendering technique for generating realistic images by tracing the path of light through a 3D scene.
+An render engine consists of a "faceless" computer program that interacts with a host 3D application to provide very specific raytracing capabilties "on demand". Blender 3D is the host application of YafaRay.
+</longdescription>
+<use>
+ <flag name="blender">install <pkg>media-gfx/blender</pkg> scripts</flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-gfx/yafaray/yafaray-0.1.1.ebuild b/media-gfx/yafaray/yafaray-0.1.1.ebuild
new file mode 100644
index 000000000000..40f9829feb6c
--- /dev/null
+++ b/media-gfx/yafaray/yafaray-0.1.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+MY_PN="YafaRay"
+
+inherit multilib
+
+DESCRIPTION="YafaRay is a raytracing open source render engine"
+HOMEPAGE="http://www.yafaray.org/"
+SRC_URI="http://static.yafaray.org/sources/${MY_PN}.${PV}.zip
+ blender? (
+ http://static.yafaray.org/sources/${MY_PN}-blender.${PV}.zip
+ )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blender debug qt4"
+
+RDEPEND="
+ dev-libs/libxml2
+ media-libs/freetype
+ media-libs/libpng
+ media-libs/openexr
+ sys-libs/zlib
+ virtual/jpeg
+ blender? ( >=media-gfx/blender-2.49 )
+ qt4? ( dev-qt/qtcore:4
+ dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-lang/swig
+ >=dev-util/scons-1.0"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Wall::g' \
+ -e 's:-O3 -ffast-math::g' \
+ "${S}"/config/linux2-config.py || die "sed failed"
+ sed -i \
+ -e "s:env.subst('\$YF_PLUGINPATH'):\"/usr/$(get_libdir)/yafaray\":"\
+ "${S}"/tools/writeconfig.py || die "sed failed"
+ # add correct paths for qt-libs
+ echo 'gui_env.Append(CPPPATH = ["/usr/include/qt4"])' >> "${S}"/src/gui/SConscript
+ echo "gui_env.Append(LIBPATH = [\"/usr/$(get_libdir)/qt4\"])" >> "${S}"/src/gui/SConscript
+}
+
+user_config() {
+ echo $@ >> "${S}"/user-config.py
+}
+
+src_configure() {
+ user_config "CCFLAGS=\"${CXXFLAGS}\""
+ user_config "PREFIX=\"${D}/usr\""
+ user_config "BASE_LPATH=\"/usr/$(get_libdir)/\""
+ user_config "YF_LIBOUT=\"\${PREFIX}/$(get_libdir)/\""
+ user_config "YF_PLUGINPATH=\"\${PREFIX}/$(get_libdir)/yafaray/\""
+ if use qt4; then
+ user_config "WITH_YF_QT='true'"
+ user_config "YF_QTDIR='/usr'"
+ fi
+ use debug && user_config "YF_DEBUG='true'"
+}
+
+src_compile() {
+ scons ${MAKEOPTS} || die "scons failed"
+ scons swig || die "scons swig failed"
+}
+
+src_install() {
+ scons install || die "scons install failed"
+ scons swig_install || die "scons swig_install failed"
+
+ if use blender; then
+ cd ../yafaray-blender
+ insinto /usr/share/blender/scripts
+ doins yafaray_ui.py
+ insinto /usr/share/yafaray/blender
+ doins yaf_*.py
+ fi
+}