summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pngrewrite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pngrewrite')
-rw-r--r--media-gfx/pngrewrite/Manifest2
-rw-r--r--media-gfx/pngrewrite/files/pngrewrite-1.3.0-gcc44.patch19
-rw-r--r--media-gfx/pngrewrite/metadata.xml5
-rw-r--r--media-gfx/pngrewrite/pngrewrite-1.3.0.ebuild30
-rw-r--r--media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild31
5 files changed, 87 insertions, 0 deletions
diff --git a/media-gfx/pngrewrite/Manifest b/media-gfx/pngrewrite/Manifest
new file mode 100644
index 000000000000..910c6e92cc5b
--- /dev/null
+++ b/media-gfx/pngrewrite/Manifest
@@ -0,0 +1,2 @@
+DIST pngrewrite-1.3.0.zip 105995 RMD160 5909e88b14d2c56e0d5bcfc02f70bcbe959207d7 SHA1 0a2a56c53e7b4cd0502c897092e859e92128d1bd SHA256 497d5b8f9fb096a2f5510711a2c76688998706a32cc93ca1709d238969d7ebc6
+DIST pngrewrite-1.4.0.zip 149760 RMD160 2be74754fba7fd878dd59a84bf17fdef4a74f2be SHA1 c959fbd507d84c6d4544d09493934b268e969b56 SHA256 24c3706bcd55b3f957b2590f1cf19ca4dd3f5bc8310db47e464140ce773a94c3
diff --git a/media-gfx/pngrewrite/files/pngrewrite-1.3.0-gcc44.patch b/media-gfx/pngrewrite/files/pngrewrite-1.3.0-gcc44.patch
new file mode 100644
index 000000000000..e514c5d3fa7c
--- /dev/null
+++ b/media-gfx/pngrewrite/files/pngrewrite-1.3.0-gcc44.patch
@@ -0,0 +1,19 @@
+--- pngrewrite.c.orig 2009-06-01 21:12:19.000000000 +0200
++++ pngrewrite.c 2009-06-01 21:12:29.000000000 +0200
+@@ -89,6 +89,7 @@
+ //#define PNGRW_SUPPORT_1_ARG_MODE
+ #define PNGRW_PALSORT_BY_FREQUENCY
+
++#include <png.h>
+
+ #include <stdio.h>
+ #include <string.h>
+@@ -109,8 +110,6 @@
+ #include <unistd.h> /* for isatty() */
+ #endif
+
+-#include <png.h>
+-
+ struct errstruct {
+ jmp_buf jbuf;
+ char errmsg[200];
diff --git a/media-gfx/pngrewrite/metadata.xml b/media-gfx/pngrewrite/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/pngrewrite/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/pngrewrite/pngrewrite-1.3.0.ebuild b/media-gfx/pngrewrite/pngrewrite-1.3.0.ebuild
new file mode 100644
index 000000000000..0a16a9862390
--- /dev/null
+++ b/media-gfx/pngrewrite/pngrewrite-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs base
+
+DESCRIPTION="A utility which reduces large palettes in PNG images"
+HOMEPAGE="http://entropymine.com/jason/pngrewrite/"
+SRC_URI="http://entropymine.com/jason/${PN}/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="media-libs/libpng"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${P}-gcc44.patch )
+
+src_compile() {
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} ${PN}.c -lpng -o ${PN} \
+ || die "compile failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+}
diff --git a/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
new file mode 100644
index 000000000000..9e2ef9f32588
--- /dev/null
+++ b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility which reduces large palettes in PNG images"
+HOMEPAGE="http://entropymine.com/jason/pngrewrite/"
+SRC_URI="http://entropymine.com/jason/${PN}/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="media-libs/libpng"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}