summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fbida/fbida-2.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fbida/fbida-2.10.ebuild')
-rw-r--r--media-gfx/fbida/fbida-2.10.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/media-gfx/fbida/fbida-2.10.ebuild b/media-gfx/fbida/fbida-2.10.ebuild
new file mode 100644
index 000000000000..9450035d19aa
--- /dev/null
+++ b/media-gfx/fbida/fbida-2.10.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Image viewers for the framebuffer console (fbi) and X11 (ida)"
+HOMEPAGE="http://www.kraxel.org/blog/linux/fbida/"
+SRC_URI="
+ http://www.kraxel.org/releases/${PN}/${P}.tar.gz
+ mirror://gentoo/ida.png.bz2
+"
+LICENSE="GPL-2 IJG"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="curl fbcon +gif lirc pdf +png scanner +tiff X +webp"
+REQUIRED_USE="
+ pdf? ( tiff )
+"
+
+RDEPEND="
+ !media-gfx/fbi
+ >=media-libs/fontconfig-2.2
+ >=media-libs/freetype-2.0
+ media-libs/libexif
+ curl? ( net-misc/curl )
+ gif? ( media-libs/giflib:= )
+ lirc? ( app-misc/lirc )
+ png? ( media-libs/libpng:* )
+ scanner? ( media-gfx/sane-backends )
+ tiff? ( media-libs/tiff:* )
+ virtual/jpeg:*
+ virtual/ttf-fonts
+ webp? ( media-libs/libwebp )
+ X? (
+ >=x11-libs/motif-2.3:0
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-proto/xextproto x11-proto/xproto )
+ pdf? ( app-text/ghostscript-gpl )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/ida-desktop.patch \
+ "${FILESDIR}"/${PN}-2.10-giflib-4.2.patch
+
+ tc-export CC CPP
+}
+
+src_configure() {
+ # Let autoconf do its job and then fix things to build fbida
+ # according to our specifications
+ emake Make.config
+
+ gentoo_fbida() {
+ local useflag=${1}
+ local config=${2}
+
+ local option="no"
+ use ${useflag} && option="yes"
+
+ sed -i \
+ -e "s|HAVE_${config}.*|HAVE_${config} := ${option}|" \
+ "${S}/Make.config" || die
+ }
+
+ gentoo_fbida X MOTIF
+ gentoo_fbida curl LIBCURL
+ gentoo_fbida fbcon LINUX_FB_H
+ gentoo_fbida gif LIBUNGIF
+ gentoo_fbida lirc LIBLIRC
+ gentoo_fbida pdf LIBTIFF
+ gentoo_fbida png LIBPNG
+ gentoo_fbida scanner LIBSANE
+ gentoo_fbida tiff LIBTIFF
+ gentoo_fbida webp LIBWEBP
+}
+
+src_compile() {
+ emake verbose=yes
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ STRIP="" \
+ prefix=/usr \
+ install
+
+ dodoc README
+
+ if use fbcon && ! use pdf; then
+ rm "${D}"/usr/bin/fbgs "${D}"/usr/share/man/man1/fbgs.1 || die
+ fi
+
+ if use X ; then
+ doicon "${WORKDIR}"/ida.png
+ domenu desktop/ida.desktop
+ fi
+}