summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2020-07-12 18:19:18 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-09 10:13:56 +0300
commit2cfe6d7166ee3c74bbe7013bd31733bd34092b1c (patch)
treed194e499f31eee37971d60cd938d159e7c795ac2 /mail-client
parentdev-python/urwidtrees: Add version bump 1.0.3 (diff)
downloadgentoo-2cfe6d7166ee3c74bbe7013bd31733bd34092b1c.tar.gz
gentoo-2cfe6d7166ee3c74bbe7013bd31733bd34092b1c.tar.bz2
gentoo-2cfe6d7166ee3c74bbe7013bd31733bd34092b1c.zip
mail-client/alot: Add version bump 0.9.1
Closes: https://bugs.gentoo.org/732362 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.9.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index a09eea039998..d260d153e1c8 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -1,2 +1,3 @@
DIST alot-0.8.1.tar.gz 220342 BLAKE2B 019f41f1f1fe73aa17a309a73b12883cbbae6a232d912d0e328b3862fc4e8e49ea6a3d0b6e2921ecb4d6ee8a58a9f6826facd7ff4cd6fafc17f6f5fe0195dd2c SHA512 bca4a01636594f0e71c6ea260d74cf26e74dfd7aca1ea7801714b4aaf9602ae7737769e77e3af0363ed2701df1494e0f87ce85b58c47a6380ad1a9098f8501d4
+DIST alot-0.9.1.tar.gz 228645 BLAKE2B 7a44542513bc6d90df43cb21daf2ba103cbbae4dd81b44eaf935d764ba11d6c5640774e72728725eca83a777dcf3583bebaa57c9061191499f74ed89d4c11b4f SHA512 ac65c742d5bfb4827482c881ec2eb95b9215e9a5c49d7001421d62ffb1f38c7792dbbf94c0f16578da70b5ce15ba7a28cea0c1bbd34080f8132c80f4a0a2199b
DIST alot-0.9.tar.gz 224932 BLAKE2B 6063b9974ec54b51521ec52db41519bd9f16cc8da611b1a2da7de3f7581a924962a79ca8193ad0bb36633141182c047f32c5ab58132c78e1ec036e4da684181c SHA512 e630ea18702c570630deb10347c52e03aecb297bc1f76ce60318eeb8725274b12eb408cbceb69c8035b1ec9ea778f19a035f48070606bc6540b68a4bc5591860
diff --git a/mail-client/alot/alot-0.9.1.ebuild b/mail-client/alot/alot-0.9.1.ebuild
new file mode 100644
index 000000000000..58b6e94fb25e
--- /dev/null
+++ b/mail-client/alot/alot-0.9.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.4[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ <net-mail/notmuch-0.30[crypt,python,${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ "
+
+PATCHES=(
+ "${FILESDIR}/0.9-0001-remove-non-working-test.patch"
+ )
+
+distutils_enable_tests unittest
+
+BDEPEND+=" test? ( dev-python/mock[${PYTHON_USEDEP}] ) "
+
+python_compile_all() {
+ emake -C docs man
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ doman docs/build/man/*
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog ""
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ elog ""
+ fi
+}