summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-11-09 21:26:58 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-11-09 23:45:33 +0200
commit8e8193f4392a2a1f533db5033420e05d35afdce4 (patch)
treeae99fa34f022c3b18ba645ac281c853870a735e4 /lxqt-base
parentlxqt-base/lxqt-config: add 1.4.0 (diff)
downloadgentoo-8e8193f4392a2a1f533db5033420e05d35afdce4.tar.gz
gentoo-8e8193f4392a2a1f533db5033420e05d35afdce4.tar.bz2
gentoo-8e8193f4392a2a1f533db5033420e05d35afdce4.zip
lxqt-base/lxqt-admin: add 1.4.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-admin/Manifest1
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-1.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index d07170799a65..da4f9a9363db 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1 +1,2 @@
DIST lxqt-admin-1.3.0.tar.xz 151148 BLAKE2B b4feae9d043ea5891b3522ecc20dea677452f532f1c17f754d13d9c506ac72e4d0deb7b52359e78c749f8784c7ceddb47574e8bb162c373afb2caa60b87765b0 SHA512 5538d20466a42c5a6e31925889ce2315bd63fc15b79ede0faacd485f10a33375f9799597601dcf3bba421e7b55797b0d7c898c2b579d878c32e79ef897735ef6
+DIST lxqt-admin-1.4.0.tar.xz 152052 BLAKE2B aa0c363d023d1c7dc21f4a1b985c41a61690ef9965a4aebc99ae4bb5ab941e02efd29a11975ddcfd6ae4d4b7c395ba383dce9865589ea78e8e652749c02393e2 SHA512 f6292006f308cd435243577c5f6cf7e7ebb6cb3ed069b26a3e8cf295e299e482255f1d39801db1e5f94cf780ec6621c8100e2ab5a2c2d5599551f1c7a2c19610
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-1.4.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-1.4.0.ebuild
new file mode 100644
index 000000000000..654cff780842
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"