summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-20 23:18:23 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-20 23:18:46 +1000
commit8fb0f406d4152e9212e9d4f255acd463f13475f7 (patch)
treea21908f4fb1e9395cfa0532216a578e3c0542b33 /kde-plasma
parentkde-plasma/plasma-desktop: virtual X is required for tests (diff)
downloadgentoo-8fb0f406d4152e9212e9d4f255acd463f13475f7.tar.gz
gentoo-8fb0f406d4152e9212e9d4f255acd463f13475f7.tar.bz2
gentoo-8fb0f406d4152e9212e9d4f255acd463f13475f7.zip
kde-plasma/kinfocenter: remove X USE flag
Building with USE="-X opengl" causes a build failure. Additionally, the X-Server information screen is not removed - it remains, but empty. Gentoo-bug: 580472 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.6.2.ebuild5
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.6.3.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.6.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.6.2.ebuild
index 551b810f8c3e..01280b4cddc9 100644
--- a/kde-plasma/kinfocenter/kinfocenter-5.6.2.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-5.6.2.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="A utility that provides information about a computer system"
HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="egl gles ieee1394 +opengl +pci samba nfs wayland X"
+IUSE="egl gles ieee1394 +opengl +pci samba nfs wayland"
REQUIRED_USE="egl? ( || ( gles opengl ) )"
@@ -36,6 +36,7 @@ COMMON_DEPEND="
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui 'opengl(+)')
$(add_qt_dep qtwidgets)
+ x11-libs/libX11
gles? (
$(add_qt_dep qtgui 'gles2')
|| (
@@ -52,7 +53,6 @@ COMMON_DEPEND="
pci? ( sys-apps/pciutils )
samba? ( net-fs/samba[server(+)] )
wayland? ( $(add_plasma_dep kwayland) )
- X? ( x11-libs/libX11 )
"
DEPEND="${COMMON_DEPEND}
$(add_frameworks_dep plasma)
@@ -72,7 +72,6 @@ src_configure() {
$(cmake-utils_use_find_package opengl OpenGL)
$(cmake-utils_use_find_package pci PCIUTILS)
$(cmake-utils_use_find_package wayland KF5Wayland)
- $(cmake-utils_use_find_package X X11)
)
kde5_src_configure
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.6.3.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.6.3.ebuild
index 551b810f8c3e..01280b4cddc9 100644
--- a/kde-plasma/kinfocenter/kinfocenter-5.6.3.ebuild
+++ b/kde-plasma/kinfocenter/kinfocenter-5.6.3.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="A utility that provides information about a computer system"
HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="egl gles ieee1394 +opengl +pci samba nfs wayland X"
+IUSE="egl gles ieee1394 +opengl +pci samba nfs wayland"
REQUIRED_USE="egl? ( || ( gles opengl ) )"
@@ -36,6 +36,7 @@ COMMON_DEPEND="
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui 'opengl(+)')
$(add_qt_dep qtwidgets)
+ x11-libs/libX11
gles? (
$(add_qt_dep qtgui 'gles2')
|| (
@@ -52,7 +53,6 @@ COMMON_DEPEND="
pci? ( sys-apps/pciutils )
samba? ( net-fs/samba[server(+)] )
wayland? ( $(add_plasma_dep kwayland) )
- X? ( x11-libs/libX11 )
"
DEPEND="${COMMON_DEPEND}
$(add_frameworks_dep plasma)
@@ -72,7 +72,6 @@ src_configure() {
$(cmake-utils_use_find_package opengl OpenGL)
$(cmake-utils_use_find_package pci PCIUTILS)
$(cmake-utils_use_find_package wayland KF5Wayland)
- $(cmake-utils_use_find_package X X11)
)
kde5_src_configure