summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-07 20:29:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:38 +0200
commitb3b5564327f160ed033b7c2d7781f0bb99f9dc85 (patch)
treebf8082f2f50b947e1305e878144414a8939194e3 /kde-plasma/plasma-nm
parentnet-misc/vde: No more ltprune (diff)
downloadgentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.gz
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.tar.bz2
gentoo-b3b5564327f160ed033b7c2d7781f0bb99f9dc85.zip
kde-plasma: Add KDE Plasma 5.15.5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.15.5.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 5162d3ec2c77..a2c112195acd 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.14.5.tar.xz 721144 BLAKE2B f9537e742be74b50ffeecee007ef91d93d108b566cf081cb4d25bc4d62c98847a74e7e69ec01b2f10e4e75eac4bc75cef90a3a47ad5ad199cec9f20c31bdaf20 SHA512 54667ff01db16bfadc1663dcf51668aed4eabcb70c3903538044bb478aeb4625d27777df13867cdf03048b6575a540de5c7baaef9e2dc2c41f458d2800daba96
DIST plasma-nm-5.15.4.tar.xz 774236 BLAKE2B ae1fa25e68b05840d7a98aed8941da96477544349465aff722d3f47690f4bc7c21d4c00d7f9d5d6410ae0655b1b7a0854ea060528972153c86f78db348365031 SHA512 1d44adf022833069414440cca08c387eeaa2c3ac6fc5675dc198d53b6c1e5bdfeec22f1ac2d3f25b248f1c51e056844b89c67f5bf899f1321057168d214da6c3
+DIST plasma-nm-5.15.5.tar.xz 777140 BLAKE2B d75ad6c04587f5bc115268f2bef50e0f6dd2b8b86957ab1f43e284988039fb7d9530cb03d86f5c49bdf6747bbb6ad123c7bc527643fe7461ed91efc93c63e563 SHA512 f3f78f40b754de5afbd63c5713e684fe3d37ae25af5a9e6ba808647e0d7d4f23456ed4b94aa8138e1fab99e7f7d7e0dffb697e0e46c99bd312bad5e2a7b9833f
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.15.5.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.15.5.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.15.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}