summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-15 18:43:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-15 19:58:27 +0200
commit8aaa30b498eae8adb4df2e40a294d872b3ff12ca (patch)
treebf82d8f8f8d514237a621ed788f3bb7146beb30a /kde-plasma/kwayland-integration
parentkde-plasma/kwayland: 6.2.1 version bump (diff)
downloadgentoo-8aaa30b498eae8adb4df2e40a294d872b3ff12ca.tar.gz
gentoo-8aaa30b498eae8adb4df2e40a294d872b3ff12ca.tar.bz2
gentoo-8aaa30b498eae8adb4df2e40a294d872b3ff12ca.zip
kde-plasma/kwayland-integration: 6.2.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-6.2.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index e74fee05f7d5..6037d367fdf5 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -2,3 +2,4 @@ DIST kwayland-integration-5.27.11.tar.xz 25708 BLAKE2B 67fe2d113955b2cdec1c3d621
DIST kwayland-integration-6.1.4.tar.xz 26420 BLAKE2B ee21cbb36234a1abbcbcb915e5e9a073767362a8b9ceb2d2fac450c4fa5e570b1c3ebc3fbc6b8291c6cf96846c747fa0f03e193e3e6462add6e13734e8136ca1 SHA512 0424f308558b3a1612426aeb5c1230617d18430029ce987178d3bcb69d34e2dfd044563fbef4d1d3d24d2a091069416a302ca376d5267f1819a2f1cad0657447
DIST kwayland-integration-6.1.5.tar.xz 26396 BLAKE2B 7394bde4d04cbdb05367c1804e18718da2144c2190889be53f8cf9a20599593f46ab1933d07b6859de82f832cb30ffde4fba363c296799b190394f974e312ea8 SHA512 02ec5089483f466ee51a1a67a523aa8bac60c45b5cb80372a81493b43294fc83735152bbadb043c5b8af484fe29799da662c9bf5261adf3da774af5ce247b5aa
DIST kwayland-integration-6.2.0.tar.xz 26392 BLAKE2B ab80480afead2ea7ee88e2b2df7429b74e3e4a96459396cb49661963a2d3d87efd4b19c12188e30704219344a6bede4f2278b93b5cd43260699423de257b5e73 SHA512 a3b3a0599a44e586df565be0b507ab720c200152ae0e3aaeb928f13790db6738d6db0aeb610af8909f961ed9ac3fda9933e289049a0ef94c8334a4281534978f
+DIST kwayland-integration-6.2.1.tar.xz 26352 BLAKE2B b021e5e4ac66f9c5feca71371d905bf0a884622b451565201afbf48436737bc10207cb643029efbfc6174f92336705c29c87fb68b79637db3698d2faa582abf3 SHA512 47ba13bcedf78c66f9f1000efcf56e6774f5d06bbec2eefa3f34bf592e4c618c4d46c3be81891393774e4e976a06a1842f54235bb2462f04e1624d204ac66495
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-6.2.1.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-6.2.1.ebuild
new file mode 100644
index 000000000000..599a5bbb2547
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-6.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ filter-lto # bug 921430
+ ecm_src_configure
+}