summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-09 19:27:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-09 21:06:30 +0200
commit75f3bdb77de6cbe367d9f34ffc29c95e4183475c (patch)
tree46ab7edb5c7b440db31907f97bc2b86df5052685 /kde-plasma/ksshaskpass
parentapp-emulation/libvirt: update live ebuild (diff)
downloadgentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.tar.gz
gentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.tar.bz2
gentoo-75f3bdb77de6cbe367d9f34ffc29c95e4183475c.zip
kde-plasma: Add KDE Plasma 5.16.3
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.16.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 7816a885044e..165b5b888030 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.15.5.tar.xz 21304 BLAKE2B 8664f783d08d789aab81e40cc6d0a7248f0fe25bab20803579ce0c3869a412d2fc8fecf709b4bfe7d900dc7b9af59042d4e648d5b5730a8fb7108f4ac39ba362 SHA512 296581dafc7068a0e536fb3f10dbd56bd288bec5b93f96e5f7d7b03be6cf9f279dbdeccc8c53da21316fa18d758e92513d8f5441d9e80dfee452c26ef1dddcbc
DIST ksshaskpass-5.16.2.tar.xz 21360 BLAKE2B 0b35b339fae72e8ad0c375b1db3bf9a3159999e02b35481aa45479b55de1835e851ae593feb638fb05adfb271f5cb07e9ea03f2fe70088350677bfcc26237fb8 SHA512 c4a2ab73bd65157226016b7b2ab1ca95d66d4ae05b775075ab676ec7cddd73ec9bc56b17d2d76b052186f0e9aad4a388aece470f97ff0b809fb03decadf07d1f
+DIST ksshaskpass-5.16.3.tar.xz 21304 BLAKE2B 8c39a5bd6f67aa1b7218340d51a1a90c14dd5de7503605f0f22d051359815601a5ec0d700020510a8e857ecd5ce95e6d06a03a4d8c1a3b36031576715ef0ef0d SHA512 cd08827870ac002dfb45362fcd2dbe0ee61e8a621cc7dc0c67d5e6f810e96db6055cd2a2dde3fe21f93c1342e8f014e25b9d5873f38da8eeea79fb08eae27bde
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.16.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.16.3.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.16.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}