summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/ksshaskpass
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.15.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index eb5425d56aa5..5901ae766d90 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.14.5.tar.xz 21332 BLAKE2B a29b1fc2802925759eaf1b9ff8dec7dd0dddcf67b2093fd6b8a9bccb112264a9f01cbc8b42e707b9782cd3efe9d272ae9ca573e3e084f5a3dfe632d88be52104 SHA512 5517193df92ad868d06bcc8f353bfd38932d0a96d98e6af38d3714478233ea91771cbb7b075e76c133d595812643a0e2fea6a6086be94845a252c215b243b37f
DIST ksshaskpass-5.15.3.tar.xz 21200 BLAKE2B 5aa2e270d91f1c745948484561be1de2d7e8ef90c60ae6bec09ed8b7e0e57eb87710419ef76d954c89ea427ccd5edee2a606b4f92c5e28c6c9d0e940651add9c SHA512 8f409769743b72338c0460e04c1463a107b02d2fdd421d15b206e11b9b69dc2be5eeae10549a4a65763ca9b743abaf91654864f0549569c2cfaf22c1c931bab6
+DIST ksshaskpass-5.15.4.tar.xz 21316 BLAKE2B 3b33e2b4fcce2d038caa788f967cb40ef0bdb262e24c6e0cb8b31ac5e4fe1f4da630e21b268df159f8c88981ee519734725a1d0b481347ce7b9289abafa0696e SHA512 bc6d580bebacd764b133cc47e4a8f53ffaf1317b8777ce5dbd419c7477be6d95fb7f75dd49d80b6e8d2812084bb009d4c75fcd287542cc8f9450319056eaa8bc
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.15.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.15.4.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.15.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}