summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-02 11:29:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-02 14:57:09 +0100
commit17105a3adb4fcbcc2c010aafd8a9b811134581eb (patch)
tree4a6c620f7ad98aa509b03e36138bbac1ab88c15b /kde-plasma/discover
parentnet-vpn/openvpn: Drop superfluous REQUIRED_USE and try to silence CI (diff)
downloadgentoo-17105a3adb4fcbcc2c010aafd8a9b811134581eb.tar.gz
gentoo-17105a3adb4fcbcc2c010aafd8a9b811134581eb.tar.bz2
gentoo-17105a3adb4fcbcc2c010aafd8a9b811134581eb.zip
kde-plasma/discover: Add missing DEPEND
Closes: https://bugs.gentoo.org/678426 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/discover')
-rw-r--r--kde-plasma/discover/discover-5.15.2-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/discover/discover-5.15.2-r1.ebuild b/kde-plasma/discover/discover-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..59f63447ccf4
--- /dev/null
+++ b/kde-plasma/discover/discover-5.15.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma resources management GUI"
+HOMEPAGE="https://userbase.kde.org/Discover"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="firmware"
+
+# libmarkdown (app-text/discount) only used in PackageKitBackend
+DEPEND="
+ $(add_frameworks_dep attica)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kirigami)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ firmware? ( sys-apps/fwupd )
+"
+RDEPEND="${DEPEND}
+ $(add_frameworks_dep kirigami)
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # we don't need it with PackageKitBackend off
+ punt_bogus_dep KF5 Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Snapd=ON
+ -DBUILD_FlatpakBackend=OFF
+ -DBUILD_FwupdBackend=$(usex firmware)
+ )
+
+ kde5_src_configure
+}