summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/about-distro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/about-distro')
-rw-r--r--kde-misc/about-distro/Manifest2
-rw-r--r--kde-misc/about-distro/about-distro-1.1.0.ebuild39
-rw-r--r--kde-misc/about-distro/files/kcm-about-distrorc4
-rw-r--r--kde-misc/about-distro/metadata.xml5
4 files changed, 50 insertions, 0 deletions
diff --git a/kde-misc/about-distro/Manifest b/kde-misc/about-distro/Manifest
new file mode 100644
index 000000000000..e1ab6ba577c0
--- /dev/null
+++ b/kde-misc/about-distro/Manifest
@@ -0,0 +1,2 @@
+DIST about-distro-1.1.0.tar.xz 26508 SHA256 829f97a27a882877cca51cfb084dfdf33670fb1bc9ccbf0b2d05187de87e721b SHA512 89b1c4a614b3ca36e6df956b8a0e82994cef4f091e789af5419fafa02ba10298e5082e22b7666647f57279cc7b3603c4fdbab675473a89eddffd137b2aa949be WHIRLPOOL ab95750073fad3eb29446470b18f896b9e259249e2ccb436b2fb61558aba1a999f49d961c22cfd7f4af57653246e8314ec3c962bd2257a7c892e964ca8a20e11
+DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb47dc3229505abbac0c6 SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48 WHIRLPOOL e161bf40c5e16180fa65217cb49314fb230c45329f4c518d6014083bd71da82d4aa048811ee814fde7fa300105cef16c182688445164ae84d0d700e23641b342
diff --git a/kde-misc/about-distro/about-distro-1.1.0.ebuild b/kde-misc/about-distro/about-distro-1.1.0.ebuild
new file mode 100644
index 000000000000..bb66b8695723
--- /dev/null
+++ b/kde-misc/about-distro/about-distro-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca cs da de el es fi fr gl hu ja ko lt nl pl pt pt_BR ro ru
+sk sl sv tr ug uk"
+inherit kde4-base
+
+DESCRIPTION="KCM displaying distribution and system information"
+HOMEPAGE="https://projects.kde.org/projects/playground/base/about-distro"
+SRC_URI="http://www.gentoo.org/images/glogo-small.png"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI+=" mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="${DEPEND}
+ sys-apps/lsb-release
+"
+
+src_install() {
+ kde4-base_src_install
+
+ insinto /usr/share/config
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
diff --git a/kde-misc/about-distro/files/kcm-about-distrorc b/kde-misc/about-distro/files/kcm-about-distrorc
new file mode 100644
index 000000000000..05aac0a2c55a
--- /dev/null
+++ b/kde-misc/about-distro/files/kcm-about-distrorc
@@ -0,0 +1,4 @@
+[General]
+Name=Gentoo Linux
+LogoPath=/usr/share/about-distro/glogo-small.png
+Website=http://www.gentoo.org
diff --git a/kde-misc/about-distro/metadata.xml b/kde-misc/about-distro/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-misc/about-distro/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>